How to run an alias in a shell script?

  • I have an executable file mpiexec, whose full path is ~/petsc-3.2-p6/petsc-arch/bin/mpiexec. Since I want to execute this command in different directories (without having to retype the entire path), I setup an alias in my home .bashrc file:

    alias petsc="~/petsc-3.2-p6/petsc-arch/bin/mpiexec"  

    which allows me to execute this mpiexec file at the command prompt easily by typing:

    petsc myexecutable

    I tried to write a shell script file, named script, using my new alias petsc as a command. After giving my shell script the appropriate permissions (using chmod), I tried to run the script. However, it gave me the following error:

    ./script: line 1: petsc: command not found

    I know that I could just write the full path to the mpiexec file, but it is cumbersome to write the full path everytime that I want to write a new script. Is there a way that I can use my alias petsc inside the script file? Is there a way I can edit my .bashrc or .bash_profile to make this happen?

    How about adding the alias to `.bash_aliases` ? Also how about aliasing the absolute path instead of relative path like `alias petsc='/home/user/petsc-3.2-p6/petsc-arch/bin/mpiexec'`

    @nitstorm: Neither solution seems to work... I still get the same error as before

    I actually just used a system link which worked for me like: `ln -sf /usr/bin/podman .local/bin/docker`

  • Panther

    Panther Correct answer

    9 years ago

    Some options:

    1. In your shell script use the full path rather then an alias.

    2. In your shell script, set a variable, different syntax

      $petsc myexecutable
    3. Use a function in your script. Probably better if petsc is complex

      function petsc () {
          command 1
          command 2
      petsc myexecutable
    4. Source your aliases

      shopt -s expand_aliases
      source /home/your_user/.bashrc

    You probably do not want to source your .bashrc, so IMO one of the first 3 would be better.

    Your suggestion 2) works, but I want to be able to use the same command in multiple shell scripts without having to write the first line petsc="...". Is there a way to do this?

    Sounds as if you should put the command in a more standard location, such as `/usr/local/bin`

    In the point 2 you do not set an alias but a variable.

    Not asked for by OP but relevant to the question title: Point 2 won't work with commands containing `|`. Here, use `shopt -s expand_aliases` & local alias, e.g. `alias myalias='echo abc|rev'` - requires line-break before use (see ALIASES in `man bash`). Point 4: Sourced file may prevent non-interactive execution, i.e. in a script. Look for early `exit` or `return`, e.g. `[ -z "$PS1" ] && return` (checks if primary prompt isn't set indicating non-interactive shell) or there may be a check for `i` in `$-` (`$-` contains shell options, `i` means interactive). See `man bash` for those variables.

  • Aliases are deprecated in favor of shell functions. From the bash manual page:

    For almost every purpose, aliases are superseded by shell functions.

    To create a function, and export it to subshells, put the following in your ~/.bashrc:

    petsc() {
        ~/petsc-3.2-p6/petsc-arch/bin/mpiexec "[email protected]"
    export -f petsc

    Then you can freely call your command from your scripts.

    That almost works... the only problem is that I need to be able to pass different flags to the executable "mpiexec"... For instance, I need to be able to execute something like "petsc -n 40 myexecutable" with the alias "petsc"

    @Paul: I added `"[email protected]"` just to handle arguments.

  • Shell functions and aliases are limited to the shell and do not work in executed shell scripts. Alternatives for your case:

    • (if you do not bother to use mpiexec instead of petsc) Add $HOME/petsc-3.2-p6/petsc-arch/bin to your PATH variable. This can be done by editing ~/.profile and appending:


      Re-login to apply these changes

    • Create the directory ~/bin and

      • make a wrapper script named petsc containing:

        exec ~/petsc-3.2-p6/petsc-arch/bin/mpiexec "[email protected]"
      • if the program allows for it, you can skip the shellscript and make a symlink using the command:

        ln -s ~/petsc-3.2-p6/petsc-arch/bin/mpiexec ~/bin/petsc
  • In bash 4 you can use special variable: $BASH_ALIASES.

    For example:

    $ alias foo="echo test"
    $ echo ${BASH_ALIASES[foo]}
    echo test
    $ echo `${BASH_ALIASES[foo]}` bar
    test bar

    Alternatively define as variable then use command substitution or eval.

    So for example, instead of defining the alias such as:

    alias foo="echo test"

    define it as:

    foo="echo test"

    instead. Then execute it by either:

    find . -type f -exec sh -c "eval $foo" \;


    find . -type f -exec sh -c "echo `$foo`" \;

    Altough aliases are deprecated in favor of shell functions, this answer os the only one which should be accepted. Even the old Debian 8 has version 4 of bash, so the `${BASH_ALIASES[alias]}` is a nice option. Otherwise i had to edit lot of lines of my .bash_aliases to apply other things. Thank you.

    Indeed. In my case, it worked like this: eval ${BASH_ALIASES[foo]} . Even managed to get through nested aliasing, e.g. foo->foo123->/smth/real

  • You can force bash to execute your script as an interactive shell with the -i flag. This will tell your .bashrc file to define aliases and other functions.


    ~ $ grep ll .bashrc
    alias ll='ls -lah'
    ~ $ cat 
    ~ $ bash line 3: ll: command not found
    ~ $ bash -i contents..

    More info:

    $ man bash

    `.bashrc` is also read during non-interactive SSH command execution (that's why it has a check for interactivity at the top)

       Aliases are not expanded when the shell is not interactive, unless the expand_aliases shell option is set using shopt (see the description of shopt under SHELL BUILTIN COMMANDS

    So the real answer to this question, for those looking to use actual aliases in shell scripts instead of alternatives to them, is:

    shopt -s expand_aliases
    alias foo=bar
    foo whatever

    As for why I'd want to do this: Due to unusual circumstances, I need to trick a Dockerfile into thinking it's a shell script.

    1. In .bash_aliases:

      petsc {
      ~/petsc-3.2-p6/petsc-arch/bin/mpiexec "[email protected]"

      Or put the function in .bashrc. Usually in .bashrc only config settings of bash are stored.

    2. In Terminal: source .bash_aliases

    3. Call it: petsc arg(s)

    Advantage: you do not need export -f petscin .bash_aliases. Aliases are deprecated but using .bash_aliases for functions is ok.

    I like this solution, I will give it a try later

    1. Use your aliases in your shell script.
    2. Source your script in your current, interactive shell instead of executing it.

    So if you have a file called with your commands that include using aliases, simply type:


    @DavidFoerster This method works fine. Sourcing a script with the `.` or `source` buiiltin causes the *current* shell to execute all the commands in it. If alias expansion would occur in the shell in which `.` or `source` is run, it occurs. However, it's important to realize that this method is only sometimes useful, because often one needs or wants to execute a script in its own shell, with its own environment. Shell scripts written with the intention of being executed in the usual way should not usually be sourced instead--they often won't work right.

    @EliahKagan: Thanks. Now I understand what the answer is supposed to mean. I'll add an explanation.

  • (EDIT: removed functions since I misread calling of mpiexec.)

    If the only thing you need is less typing, why don't you just put the folder in $PATH? Or make a symlink to mpiexec from some folder in $PATH? Or (my favourite) put the alias in a script that you source in the calling script?

    The reason why I can't put it into my $PATH is because I have another 'mpiexec' file in another directory that is alredy in my $PATH. If I add the path to this new 'mpiexec', it will probably try to execute both of them... wouldn't it?

    Cannot understand why not simply use `"[email protected]"`.

    Paul, it'll try to execute the one that's first in the PATH, not both.

    enzotib, ah I misread the way mpiexec was called, I thought it needed all args as one. Will edit my answer :)

License under CC-BY-SA with attribution

Content dated before 6/26/2020 9:53 AM