Reverse two finger scroll direction (natural scrolling)?

  • Two-fingered scrolling is working fine, but is there a way that I can reverse the direction (natural scrolling)? It seems backwards opposed to the way OSX does it.

    I've been using this for a day and now I want to reverse the direction my Up and Down arrow keys scroll the page.

    `gsettings set org.gnome.desktop.peripherals.touchpad natural-scroll true` worked for me on 16.04

  • I don’t know which version of Ubuntu you’re using, but in 13.04 (and I guess in 12.10) it’s possible via touchpad settings.

    So first, open System Settings > Mouse and Touchpad. As seen in the screenshot below if there’s an option for content sticks to fingers, check it. Then the scrollbars will work in reverse direction.


    This is also accessible via DConf Editor as well. Go to org.gnome.settings-daemon.peripherals.touchpad and check natural-scroll.


    You can also set this option on the command line:

    gsettings set org.gnome.settings-daemon.peripherals.touchpad natural-scroll true
    

    Finally, it's about time they implement something like this :)

    I didn't consider the date of question! :D

    I think this is essential for Ubuntu Touch, where you move the content itself instead of scrollbar slider.

    Unfortunately, it doesn't work in Nautilus and few other applications, though it works in others

    The **System Settings > Mouse and Touchpad** for 14.04 is listed as *"Natural scrolling"* and works well, including Nautilus.

    And it doesn't work with all laptops. This setting does _nothing_ on my HP laptop. syncclient VertScrollDelta -111 (suggested in another answer) does. The same is true with palm detection.

    If you want to set the scroll direction without GUI use the following command in your terminal (this sets the setting permanently per user): `gsettings set org.gnome.desktop.peripherals.touchpad natural-scroll false` or for your mice `gsettings set org.gnome.desktop.peripherals.mouse natural-scroll false`. (Fedora 24 recognizes your mouse as touchpad, therefore use the command line with `.touchpad`, see http://forums.fedoraforum.org/showthread.php?p=1778162&;posted=1#post1778162 and the Fedora bug https://bugzilla.redhat.com/show_bug.cgi?id=1352159

    loged in to thank for this mehod) +1

    @erik Nice CLI approach, but doesn't work for me: first, I have a slightly different path (I have "settings-daemon" where you have "desktop"), second, flipping the "natural-scroll" from true to false and back has no impact on the touchpad's behaviour (as observed in Ffox, a terminal and nautilus) and third, I have no "mouse.natural-scroll" to try out. Any suggestions?

    unfortunately dConf doesn't seem to affect my scrolling in Ubuntu 18.0.4 with Apple's Magic Trackpad 2, trackpad works for moving pointer and clicks but scrolling doesn't work.

  • There are several ways to enable system-wide inverse or natural scrolling for the mouse. Only two ways I have tried will enable it for all windows, including gedit, terminal, software center, nautilus, and others. The easiest way to do it is to do the following. This method will need the latest version of the xserver-xorg-input-evdev driver, which you can get from here. I know it will work because I am using it and tested it previous to writing this version of a guide I previously wrote for Fedora 21. Make sure that you have reverse scrolling turned off in Ubuntu-Tweak, or you won't see the effect of the changes. In addition, for those users who do not want to use natural scrolling on your system now that reverse scrolling will be system-wide, those users can use this option to turn off natural scrolling on a per user basis. Now, to get started...

    Update/install Evdev to latest version and reboot before continuing this guide.

    Get your mouse device id by running the following in a terminal:

    xinput list
    

    Take that number you got (just the number after "id=") and replace "{device id}" with that number in the following command:

    xinput list-props {device id} | grep "Scrolling Distance"
    

    It is case sensitive unless you use -i in the grep command. Write down the numbers you find in the output from that command (in my case it was the number 1, shown three times and separated by commas). You will use the negative values of the numbers you get in your output. Also, make sure to write down the property number (it will be in parentheses in the output; in my case it was (272) in Ubuntu and (273) in Fedora).

    Note: If you get no output containing the property "Scrolling Distance" this method will not work for you and you will need to stop here and skip to the alternate way shown below this guide.

    Run the following command in your open terminal:

    sudo touch /usr/share/X11/xorg.conf.d/20-natural-scrolling.conf
    

    Now, run the following command (you can use your favorite text editor instead of nano but I use nano):

    sudo nano /usr/share/X11/xorg.conf.d/20-natural-scrolling.conf
    

    In the file you have opened in your preferred text editor, paste the following (but be sure to change the numbers to the same comma-separated numbers you got from step 3; in my case the number was 1 so I put -1):

    Section "InputClass"
            Identifier "Natural Scrolling"
            MatchIsPointer "on"
            MatchDevicePath "/dev/input/event*"
            Option "VertScrollDelta" "-1"
            Option "HorizScrollDelta" "-1"
            Option "DialDelta" "-1"
    EndSection
    

    Save the file and exit the text editor. No need for a reboot. Just issue the following command (substituting the property number and the negatives of the numbers you got in the third step, and the device id you got from the second step):

    xinput set-prop {device id} {property number} -1 -1 -1
    

    You might need to quit nautilus and restart nautilus on some systems (skip this if natural scrolling is working in nautilus after running the above command). Press Alt+F2 and run each of these commands separately:

    nautilus -q
    
    nautilus -n
    

    That's it! You should now have system-wide natural scrolling that will be persistent.

    Alternate method:

    If you do not want to install the latest version of Evdev (or, if your mouse doesn't have the "Scrolling Distance" property even in the latest Evdev), you can do the following:

    Run the following command in your open terminal:

    sudo touch /usr/share/X11/xorg.conf.d/20-natural-scrolling.conf
    

    Now, run the following command (you can use your favorite text editor instead of nano but I use nano):

    sudo nano /usr/share/X11/xorg.conf.d/20-natural-scrolling.conf
    

    In the file you have opened in your preferred text editor, paste the following:

    Section "InputClass"
            Identifier "natural scrolling for mouse wheel"
            MatchIsPointer "on"
            MatchDevicePath "/dev/input/event*"
            Driver "mouse"
            Option "Device" "/dev/input/mice"
            Option "Protocol" "Auto"
            Option "ZAxisMapping" "5 4"
    EndSection
    

    Save the file and reboot. As above, individual users can switch it off on a per-user basis by using Ubuntu-Tweak to "turn on" natural scrolling (it will be the reverse of the system-wide setting on a per-user basis but will not affect the actual system setting for other users who will want to use natural scrolling).

    Note: The alternative method here will not work if you have the latest Evdev installed, such as in Fedora 22. Use the Evdev method above. Also note: Neither method will work with libinput in Wayland. You will need an alternative way of doing it per user or otherwise. If using libinput, make sure to remove the files created as above, and create a startup item in a desktop file. After creating the desktop file, place the following in the Exec line (be sure to use the device id for your mouse and the naturalscrolling property number for your mouse while using libinput; my device id was 11 and the property was 272; adjust yours accordingly).

    sh -c "sleep 5; exec xinput set-prop 11 272 1"

    Following that, save the file and logoff. When you logon again you should have natural scrolling on a per-user basis or may be able to set it in the autostart for all users.

    Perfect! I did not have to use the alternative method. Lenovo Helix, Arch Linux, Gnome 3.16 and Logitech MX wireless mouse. THANK YOU!

    Thank you! For other users (with multiple keyboards like me)... the part about xinput set-prop etc. in this answer is only necessary to avoid reboot.

    The 'alternate method' without evdev did not work for me on Fedora 22 and made the mouse pointer unresponsive (failed to load mouse module).

    Yes, I found that the alternative method no longer works with Fedora 22 and above. You get to choose between Evdev or libinput. If you install the Evdev driver, please do not use the alternative method. It won't work. With Fedora 22 you get one of the latest versions of Evdev anyway so the alternative method is a moot point in that version although it still works in other distributions until the newest changes become incorporated in them. I recommend Evdev rather than libinput. Libinput still is very buggy and will not work with either method here.

    First method works like a charm. Ubuntu 15.4 and Microsoft Touch Mouse. Thanks!

    This works for me when I use 2-finger scrolling, but not when I use circular scrolling. I tried setting a negative value for "Synaptics Circular Scrolling Distance" but it doesn't scroll at all then. Any ideas?

    Not sure about how to help circular scrolling. I do not have the hardware to test. I do know that certain hardware will lose all scrolling when the negative number value is too low. I tried setting that number lower to get faster scrolling and I ended up getting no scrolling at all. If you are already at -1 there isn't anything that can be done at the moment. But, if you used another number (say, -108 or something else), try setting it to -1 and see where that gets you. Try using a different parameter. Also, some devices require lower numbers than -1, such as, say, -200 or some other.

    Got it on elementary OS 0.3.2 Freya! First method doesn't work in several apps like Terminal and Skype, but second method works everywhere! Thanks a lot!

    Second method worked for me in Ubuntu 14.04 and first method worked for me in Ubuntu 16.04. Second did not work on Ubuntu 16.04. Probably because of latest evdev..

    In Ubuntu 16.04, similarly to Meharoof, the first method worked (for a bluetooth mouse), and the second didn't (for my trackpad). Any ideas how to make it work for trackpad (which list-props shows Device Enabled; Coordinate Transformation Matrix; Device Product; and Device Node only)? Thanks

    I wonder if it is possible, using the first method, to put a little 2-liner in `~/.xinitrc` just using `xinit set-prop`. I.e., is the change to a .conf file even necessary?

    To set it permanently off, per user, you can use the following command: `gsettings set org.gnome.desktop.peripherals.touchpad natural-scroll false` (for the touchpad and also for Fedora 24 mice (bug in Fedora 24)) or `gsettings set org.gnome.desktop.peripherals.mouse natural-scroll false`. See http://forums.fedoraforum.org/showthread.php?p=1778162&;posted=1#post1778162 and the Fedora bug https://bugzilla.redhat.com/show_bug.cgi?id=1352159

    Setting `synclient VertScrollDelta=50` did the trick for me

    this worked perfectly on Ubuntu 16.10, but stopped working after upgrading to Ubuntu 17.04. here is what helped for Ubuntu 17.04 in my case: https://askubuntu.com/a/905625/424125

    100% works with Synaptics touchpad driver.

    The first method works on Ubuntu 18.04 too (the other one I've not tested), even without Evdev (it might be that I'm not aware of having it in my system, actually...). I used a different header for the `.conf` file, taking it from the Arch wiki.

    This method is still working in 2019! I just used this explanation to fix scrolling issues in Xubuntu 19.10.

  • The simplest and in my opinion the best way to achieve this on Ubuntu 12.10 and above (didn't test it on 12.04 and below) is to edit synaptics configuration:

    sudoedit /usr/share/X11/xorg.conf.d/50-synaptics.conf
    

    On 16.04, copy this file under /etc/X11/xorg.conf.d/50-synaptics.conf, then edit:

    cp /usr/share/X11/xorg.conf.d/50-synaptics.conf /etc/X11/xorg.conf.d/
    sudoedit /etc/X11/xorg.conf.d/50-synaptics.conf
    

    add those lines in the Section "InputClass" Identifier "touchpad catchall":

            Option "VertScrollDelta" "-111"
            Option "HorizScrollDelta" "-111"
    

    So that it reads like follows:

    Section "InputClass"
            Identifier "touchpad catchall"
            Driver "synaptics"
            MatchIsTouchpad "on"
            Option "VertScrollDelta" "-111"
            Option "HorizScrollDelta" "-111"
    # ...
    

    Reboot (or read on) and have fun with natural scrolling :)

    If you want to try your settings without reboot, you can use synclient

    synclient VertScrollDelta=-111
    synclient HorizScrollDelta=-111
    

    The changes are immediately applied, but won't stay after reboot if you don't add them in 50-synaptics-conf file.

    Note for GNOME or Cinnamon:

    If you're using GNOME or Cinnamon desktop manager, there is a good chance that GNOME/Cinnamon's settings can override your custom settings. To prevent GNOME/Cinnamon's settings override yours, open dconf Editor [dconf-editor] and edit following entry:

    /org/gnome/settings-daemon/plugins/mouse/
    or
    /org/cinnamon/settings-daemon/plugins/mouse/
    

    Uncheck active.

    P.S.:

    The default value is 111 and it indicates the speed, that means you can play with the value to adjust the scrolling speed to you favor. Giving it a negative value makes it simply to scroll in reversed direction.

    This works in 12.04 as well, but not for Nautilus.

    In 13.04 works for Files (Nautilus). I don't know why it wouldn't work in 12.04. I used this approach in 12.10 and now using in 13.04.

    Ubuntu 12.04 uses Nautilus version 3.4.2. I believe newer versions of Ubuntu uses newer versions of Nautilus.

    +1. I was hoping to make `VertEdgeScroll` go the opposite way from `VertTwoFingerScroll` but they appear to be booleans and it's probably a crazy idea anyway. http://www.x.org/archive/X11R7.5/doc/man/man4/synaptics.4.html

    `50-synaptics-conf` should probably be `50-synaptics.conf`, otherwise this worked for me on Lubuntu 14.04.

    @PeppeL-G yes, thanks for the attention, I'll correct it immediately.

    This is probably the best solution because it is independent from the desktop environment used. For my Ubuntu 14.10 the `xorg.conf.d` folder and the file didn't exsist so I needed to create them manually and create a custom `InputSection`

    This is a great answer, as it should work on any Linux distro that uses X.org.

    This answer works well for Ubuntu GNOME 16.04 running gnome-shell 3.20 - the trackpad was inverted and couldn't find a desktop option to change it.

    If you're a moron like I am and put these settings in the wrong spot because you read through too fast and didn't pay attention, it will cause X to fail at boot, leaving you with a black screen. Luckily, you can use Ctrl + Alt + F1 or whichever F key to switch to a login console and correct your mistake there.

    @BillyBrawner I've updated the answer and added the snippet for the whole section.

    Moreover, I've added an info for 16.04, that the file should not be edited directly. This may also be valid for older versions, but I don't have any older Ubuntu for the moment to test it.

    Note it is not exactly speed, but inverse of speed: higher (absolute) values mean lower scrolling speed. 111 and -111 scroll slower than 31 and -31

  • UPDATE: This solution does not work for apps that use GTK3, such as core Gnome apps like Nautilus (file browser). See D Charles Pyle's answer below for a workaround that works in all applications. Or follow Gnome bug 682457 for progress on a core fix that won't require a workaround.

    You can use "Natural Scrolling" to have a system wide inverse scrolling.

    What is Natural Scrolling?

    Natural Scrolling is a GNOME Applet allowing you to reverse the direction of scrolling. You push your fingers upwards to move the page content upwards (and downwards for downwards) just like on iOS devices. Don't move scrollbars anymore but your file.

    Install Natural Scrolling:

    Natural Scrolling can be installed from its PPA.

    Hit Alt+Ctrl+T to open terminal and run following commands:

    sudo add-apt-repository ppa:zedtux/naturalscrolling
    sudo apt-get update
    sudo apt-get install naturalscrolling
    

    How to enable Natural Scrolling?

    Once installed, Hit Super key (Windows key) to open Unity dash and search for "natural scrolling" and open it. You'll see a new indicator in Unity panel, Click on it and select your device. In the preferences you can set it to start at login. That's it!

    enter image description here

    Is it possible to hide the icon?

    It didn't work on system windows such as nautilus and USC.

    Did not work for me on Fedora. The answer by Pyle actually works under all circumstances (terminal, eclipse, etc.). See http://askubuntu.com/a/519859/277750

  • On Ubuntu 14.04, go to "Mouse & Touchpad" and select "Natural Scrolling".

    enter image description here

    This work for me on 16.04, but I have to check natural scrolling and restart :)

  • The reverse scrolling you're talking about is called "natural scrolling," and can be enabled several different ways in Ubuntu. Here's an article on OMG! Ubuntu! detailing how to install the software that will get you what you need. If you're familiar with Ubuntu Tweak, you can also enable it in the latest release.

    Awesome, thanks. "Natural Scrolling" in Ubuntu Tweak messes with the mouse as well, I'll see if the `.Xmodmap` tweak works.

  • Get the device-id using:

    xinput list
    

    Get the numbers from this command:

    xinput list-props {device id} | grep "Scrolling Distance"
    

    For example, a sample output:

    Synaptics Scrolling Distance (290): 102, 102
    

    Here, the numbers 102, 102 are of our interest. In your case, they would be something else. Just put negative of those numbers in the below mentioned config.

    Edit ~/.profile and put these lines at end of file.

    synclient VertScrollDelta=-102
    synclient HorizScrollDelta=-102
    

    Logout and login, natural scrolling should work fine.

    The most popular approaches at the top didn't work for me on Xubuntu 14.04. This one did!

    This was the only thing that worked for me on GNOME + Arch. THANK YOU

    These lines should be placed in ~/.xsessionrc, not ~/.profile

    Ubuntu 17.10 has "natural-scroll" checkbox in Mouse settings, but has not effect. Tried dconf-editor too, which also didn't enable natural-scrolling. This is the only method that worked.

  • The Natural Scrolling application referred to in Basharat Sial's answer does not fix natural scrolling in certain system windows.

    As an alternative, I recommend the guide provided in this answer. You won't need the natural scrolling application anymore when you use his guide.

  • The easiest way to set natural scrolling system-wide and for it to work with all system apps, is to set up the following file(s).

    Touchpads only:

    /usr/share/X11/xorg.conf.d/20-natural-scrolling-touchpads.conf

    Section "InputClass"
        Identifier "Natural Scrolling Touchpads"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Option "VertScrollDelta" "-111"
        Option "HorizScrollDelta" "-111"
    EndSection
    

    Mouses only:

    /usr/share/X11/xorg.conf.d/20-natural-scrolling-mouses.conf

    Section "InputClass"
        Identifier "Natural Scrolling Mouses"
        MatchIsPointer "on"
        MatchIsTouchpad "off"
        MatchDevicePath "/dev/input/event*"
        Option "VertScrollDelta" "-1"
        Option "HorizScrollDelta" "-1"
        Option "DialDelta" "-1"
    EndSection
    

    For both mouses and touchpads, create both files.

    Then, reboot.

    The benefit of using one of these two configurations is they are not device-specific. You can plug in other mouses or touchpads or keyboards with touchpads, and it'll work.

    worked on ubuntu 17.10

  • Please follow below steps to system widely change the scrolling.

    1. On Terminal write: xev -event mouse. You will get one small box and when you bring your mouse into that section you will get a lot data getting generated into the Terminal.
    2. On scrolling up, note the button name, lets say "x" (in my case it is button 5). Also note down the button name on scrolling down, lets say "y". in my case it is "4".
    3. Create a backup of ~/.Xmodmap file by using cp ~/.Xmodmap ~/.Xmodmap.bak.
    4. Do cat ~/.Xmodmap. Output would be like pointer = 1 2 3 5 4 6 7 8 9 10 11 12
    5. In the above output search for x and y and they will be in consecutive position and just swap them. In my case echo "pointer = 1 2 3 4 5 6 7 8 9 10 11 12" > ~/.Xmodmap && xmodmap ~/.Xmodmap worked. Note switch of 4 and 5.
    6. Now the scrolling will be applied system wide. No need to reboot.

    For most users this can be reduced to a single instruction: `echo "pointer = 1 2 3 5 4 6 7 8 9 10 11 12" >>~/.Xmodmap && xmodmap ~/.Xmodmap`

License under CC-BY-SA with attribution


Content dated before 6/26/2020 9:53 AM