How can I copy/paste files via RDP in Kubuntu?

  • I recently installed the latest Kubuntu (x64) on my work machine as I am trying to migrate away from Windows. Unfortunately I use RDP very frequently to connect to customer's servers and need to be able to copy files across.

    I have tried the following packages with no luck:

    remmina rdesktop xfreerdp

    My latest attempt to solve this involved connecting one of my folders to the remote server, here is the command I used to launch rdesktop:

    rdesktop -5 -K -r disk:home=/home/dai -r clipboard:CLIPBOARD -r sound:off -x l -P 192.168.0.2 -u "administrator" -p pass
    

    The servers are not all running the same version of Windows, the one I've been trying so far is running Server 2003 R2. Customer servers range from Server 2000 to Server 2008.

    I've been Googling this like mad but all the solutions I find seem to fail, maybe because almost all the help out there assumes that I'm running Gnome.

    Sorry if this is a stupid question.

    Thanks in advance for your help.

    Edit: Copying and pasting text seems to work just fine, but that's not what I need.

  • https://gitlab.com/Remmina/Remmina/issues/243 says that shares show up using Remmina when you also enable sound redirection. To recap, here is what you have to do:

    1. Create a Remmina RDP connection to the windows machine
    2. Edit that connection.
    3. Under the Basic tab Choose a share folder
    4. In Advanced tab, change sound to local. Save it and connect

    Then the shared folder appears in My computer in windows.
    (If it does not appear, trying clicking Refresh).

    It's rediculous, but it works :)

    +1 the only answer that worked for me

    Works also with `rdesktop -r sound:local -r disk:nameOnHost=/home/user/windows` (does not work with `~`)

    just to add you have to goto folder properties and click Local Network Share and click checkbox and allow sharing that only it will appear in windows RDP

    What an answer.. Choose a share folder? Where? In Ubuntu? In Remmina? Where in Remmina? I'm surprised this answer has so many upvotes.

    @KarlMorrison 1. Create a Remmina RDP Connection (should be obvious what it means). 2. While you're at it, *choose* a shared folder. If you look around your chances of finding this option will increase by a factor of 10. 3. In advanced tab, change sound to local.. Pretty self explanatory. Which part is confusing?

  • Quoting from the man page (http://linux.die.net/man/1/rdesktop):

    -r comport:<comport>=<device>,... Redirects serial devices on your client to the server. Note that if you need to change any settings on the serial device(s), do so with an appropriate tool before starting rdesktop. In most OSes you would use stty. Bidirectional/Read support requires Windows XP or newer. In Windows 2000 it will create a port, but it's not seamless, most shell programs will not work with it.

    -r disk:<sharename>=<path>,... Redirects a path to the share \tsclient\ on the server (requires Windows XP or newer). The share name is limited to 8 characters.


    Thus, something like this should work:

    rdesktop -r disk:sharename=/home/dai -P 192.168.0.2
    

    Ah, it appears that Windows doesn't show it in My Computer but I can navigate to it, thanks.

    I don't suppose you know how to access the share using remmina? \\tsclient is empty even though a share is set. Remmina works better fullscreen than rdesktop so I'd rather use that.

    how to you navigate to it when it doesn't show in My computer? using commandline? what is the windows path to refer to the share?

  • Another option would be (if it is suitable of course) to use shared foler, which you can define in the connection profile of remmina.

    Go to connection profile and at the bottom define a folder to share with remote machine.

  • It is strange, but rdesktop requires to share disk and sound together:

    redsktop -r sound:local -r disk:share=/home/me
    
  • with xfreerdp:

    xfreerdp "/v:hostname.example.com" "/u:myusername" /drive:tmp,/tmp
    
  • Tip: when using rdesktop -r disk:sharename=/home/user/whatever use direct path, using ~/whatever won't work.

  • Using remmina (1.2.0), it's an option in the gui:

    • Edit your connection
    • Check on 'Share folder' and select one folder in the host.

    Where should I see in the Windows computer?

    It appears under This PC

  • With KRDC v17.04.3, drives mounted at /media were automatically visible for me in Windows Explorer in a System Folder named media.

  • In Remmina RDP connection in Windows server and no transfer files.

    Easy in software manager just look for file transfer. Like Sshfs - Filesystem client based on SSH File Transfer Protocol Install it.

  • 1) Open your ~/.local/share/remmina/*.remmina file (backup first) 2) Set absolute path to sharefolder= option 3) Reconnect. Shared folder should be visible in Windows Explorer

License under CC-BY-SA with attribution


Content dated before 6/26/2020 9:53 AM