How can I change or install screensavers?

  • I want to change the default screen saver in Ubuntu 11.10/12.04. On 11.04 I just did a

    sudo apt-get install xscreensaver-data-extra xscreensaver-screensaver-bsod 
    

    And then I could change it in the control center -> screen saver options.

    Now there seems to be no other option to change the default screen saver.

  • fossfreedom

    fossfreedom Correct answer

    9 years ago

    Background

    The Gnome 3 Devs dumped the old gnome-screensaver. The replacement screensaver is just a blank screen.

    The Canonical Devs thought it was a useful idea to continue and raised a blue-print for implementation in Oneiric.

    A few ideas were raised such as a Compiz specific implementation or reusing a Lubuntu/Xubuntu screensaver implementation.

    However, at the time of writing, no implementation has been started.

    XScreenSaver

    installation

    Potential workaround - installing xscreensaver

    sudo apt-get install xscreensaver xscreensaver-gl-extra xscreensaver-data-extra
    

    Now remove gnome-screensaver

    sudo apt-get remove gnome-screensaver
    

    Now start the xscreensaver configuration tool - from a terminal:

    xscreensaver-demo
    

    or search from the Dash:

    enter image description here

    Click OK to both prompts asking to turn-off Gnome Daemon and to start xscreensaver-daemon respectively.

    dash search

    starting xscreensaver from login

    Now to start the xscreensaver daemon on login you need to search in Dash for startup applications

    Create a new entry running the command xscreensaver -nosplash

    Locking the screen

    If you want to manually lock the screen with the keyboard combination CTRL+ALT+L then you will need to run the following to repoint the old gnome-screensaver lock to xscreensaver

    sudo ln -s /usr/bin/xscreensaver-command /usr/bin/gnome-screensaver-command
    

    Logout or reboot for all changes to take effect.

    This works great for me :) ... thanks for the help i now got the good old bsod again

    I wish I could upvote this more than once....

    This works in 13.05. :)

    I recommend also Really Slick Screen Savers sudo apt-get install rss-glx

    For 14.10 this doesn't work :(

    What's the command name of the GUI on the screenshoot? `screensaver` says «command not found», and `xscreensaver` is just a command line tool.

  • Ubuntu 11.10 doesn’t come with screensaver package installed. You must install xscreensaver if you want screensavers activated when your computer becomes idled.

    1. sudo apt-get remove gnome-screensaver
    2. sudo apt-get install xscreensaver xscreensaver-gl-extra xscreensaver-data-extra enter image description here

    Links

    1. http://en.wikipedia.org/wiki/Screensaver
    2. http://ubuntuforums.org/showthread.php?t=1860551
    3. http://www.liberiangeek.net/2011/10/enable-screensavers-in-ubuntu-11-10-oneiric-ocelot/
    4. http://www.liberiangeek.net/2011/10/enable-screensavers-in-ubuntu-11-10-oneiric-ocelot/

    Disclaimer

    Above method works in 11.10 ,i didn't tried in 12.04

    Tried it on 12.04 and i works like a charm!!

  • Please take note that, for Ubuntu 12.04 and in order to be able to run several screensavers using images from the harddisk (e.g., Carousel, Gleidescope, GLSlideshow, Jigsaw, or XAnalogTV) , I had to install some additional packages.

    These are:

    • libxss-dev
    • libxss1-dbg
    • libxss1
    • kdelibs-bin
    • kdelibs5-data
    • kdelibs5-plugin

    Many others might get installed automatically together with the ones listed, particularly KDE libraries.

    I found the instructions in this blog.

  • If you sudo apt-get remove gnome-screensaver but then sudo apt-get install rss-glx (see this Ubuntu Forums post and this one), the Really Slick Screensaver (GLX) effects will run on top of a screen that has not been blanked under Unity in Ubuntu 12.04 LTS, not just in xscreensaver-demo but also when the real screensaver kicks in.

    Hence, a solution is required that does (even in the absence of gnome-screensaver) blank the screen prior to running the xscreensaver (which does work fine under LXDE for one thing).

  • There is no screensaver by default in Ubuntu. You can install xscreensaver from the archives.

    I'm not entirely sure screensavers actually do save screens anymore, though I'm inclined to think they don't. But they do consume large amounts of energy that could be better used for other things.

    They prevent image burn-in on LCDs. And the amount of energy consumed by CPU is less than what Flash applets in a browser consume during normal day.

    Switching off a monitor is a more efficient way to save both energy and the screen, wouldn't you say? This wasn't always possible.

    Indeed. Though, there's a corner case - I don't want to warm up the monitor every time I'm away for less than 10 minutes, but would like it to auto-lock my screen. Blank screen is still there in Gnome, and why not replacing it with some fun pictures.

    It encourages people to not power down their monitors, is one answer.

License under CC-BY-SA with attribution


Content dated before 6/26/2020 9:53 AM