How do I remove the Unity launcher?

  • How can we remove the launcher that come with Unity on this new Ubuntu version ?

  • In simple words: you can't. By design, the launcher is intended to stay there always. If you want to give it up, the only way to do so is to give up the entire unity interface by switching to some other DE or by switching to the classic GNOME session.

    Moving the launcher to some other edge of the screen is also not implemented and wouldn't be, as per Mark's comment on a bug.

    I won't to switch to another DE, I tried I don't like them. I use Cairo-Dock and I would like to get rid of the launcher permanently. Why is this impossible. Why are there artificial limitations? Why is this design accepted?

    One may add to this answer that there are ways to make launcher autohide, since this is an accepted answer

    I completely agree with 4xy's points. wtf? This is exactly the kind of behaviour that made me switch to Linux from Windows! Can we raise this somewhere? Thanks for your clear answer Bilal! Of course this doesnt go against you.

  • In 12.04, you can go to System Settings > Appearance > Behavior and turn on autohide, then turn the sensitivity all the way down. Now the launcher will only show when you press Super.

    Or if you drag icons to the left side of the screen (an issue if you install a dock with drag-n-drop features).

    In 11.10 it's an issue if you drag anything at all (images from a webpage, for example).

    13.04: you can choose the top left corner only (not the whole left side)

    1. Install ccsm (Compiz Config Settings Manager)

    2. Launch ccsm and click on the "Unity Plugin"

    3. Under "Behavior", change "Hide Launcher" to "autohide"

    4. Change "Reveal Mode" to None.

    5. Disable "Key to show launcher" and "Key to put focus on launcher"

    *Disabling "Key to show launcher" may prevent you from accessing the dash. If you omit this part of step 5, you can access the dash, but the launcher will appear non-invasively while the dash is displayed. I don't know of any way to stop this.

    Update: 12.04 does things differently, thus this may not work after 11.10.

    Step 4 is not available in 12.04. See the answer by WarriorIng64 for a workaround.

    12.04 was released one day before you posted. My answer from February applied to 11.10. ;) I'll update it nonetheless.

    With multiple monitors, you may need to change the "Edge stop veliocity" (experimental) to 1 in order to prevent the mouse pointer from getting "stuck" moving between monitors.

    In 12.10 Compiz does not have "none" option for reveal mode.

    @pthurmond as my answer mentions, this may not work after 11.10

    @weberc2 I'm just clarifying for other readers that it definitely doesn't work.

    yes, this does the job pretty well in ubuntu 14.10 i removed the launcher and installed plank dock. looks pretty neat.

  • You could do the following:

    1. Install and launch the ComizConfig Settings Manger.
    2. Select the Ubuntu Unity Plugin.
    3. Set the Hide Launcher option to 'Autohide'.
    4. Set the Reveal Mode option from 'Left' to 'None'.

    That should do the trick. You may need to execute setsid unity for the changes to apply.

    +1 for effort. But it's still there until something pushes it out of the way.

    I'm certain. I read those exact steps on another website. Followed them. Same deal, even though auto-hide is selected it's acting much like one would expect from dodge windows.

    Actually, now that I try alternatives. No matter what I set it to, it dodges.

    Perhaps that option just isn't taking. Is there a method to apply the change without ccsm?

    Same for me... Autohide + none, I checked plugin is activated... But still have this stupid pannel. I am not using Unity 2D.

    using gconf-editor I can see the option, apps/compiz-1/plugins/unityshell/screen0/options/launcher_hide_mode ... but it doesn't seem to have any effect when I change it manually.

    @Profete162 can you try running `unity --replace`?

  • You can go back to the classic GNOME session as described in this answer.

  • In the file /usr/share/unity-2d/shell/Shell.qml, and can be edited with the command

    gksudo gedit /usr/share/unity-2d/shell/Shell.qml
    

    The way to remove the remnant bar that was floating there was to set:

    LauncherLoader {
    id: launcherLoader
    anchors.top: parent.top
    anchors.bottom: parent.bottom
    width: 0
    

    ^Change the width to either 0 or 1, 1 will show 1 pixel, but will not produce graphic artifacts.


    Is there a less hack-y way to do this?

    The other file can be edited using

    gksudo gedit /usr/share/unity-2d/shell/launcher/Launcher.qml
    

    I am aware of the autohide feature in CCSM, however that is not what I am looking for. I wanted to place a separate launcher OVER unity, and the sensitivity of autohide would make it difficult to use both.

  • in compiz i went to the unity section and then the experimental tab and set these values to simply 'fool' the bar into never appearing unless the super button is pressed. If I can get the dash to separate from the bar entirely and move it to Cairo dock i will be extremely satisfied. ...........anyway Experimental Tab

    • panel opacity 0.0050
    • Launcher Opacity 0.0000
    • Reveal Edge 0.2000
    • Reveal Pressure 999 (this is the main one so mouse cant grab window)
    • Edge Overcome pressure 1
    • mouse pressure decay 1
    • edge stop 1
    • menu fade in and the rest are all 0
    • launcher captures mouse ....UNCheCkEd

    this way their is no hacking just a little easy tweaking and dash is still there and bar is only visible when hitting dash ...... i guess i could go remove all the launchers from it now and then it would hardly be noticeable.....cheers

    you can also go in the config editor and change these values with greater range

  • at least, you can set it to "autohide", ccsm has an option for that

    1. Install CompizConfig Settings Manager Install compizconfig-settings-manager (CCSM).
    2. Alt + F2
    3. type about:config and press Enter
    4. change the hide launcher setting to autohide.

  • Important:


    If would you want gnome panels before disabling launcher;


    Navigate to System>Preferences>Startup Applications

    Click Add

    Name=Gnome panels
    
    Command=gnome-panel
    

    And click close button.

    It's ok.


    -Unity with gnome panels


    Press SUPER key and type

    ccsm
    

    than press ENTER.

    Disable unity plugin from Compiz Config window (uncheck click box)

    Logout & Login to Ubuntu session

    -Unity without launcher ...
    

    Decent's answer is a kind of solution, but if you do so, you get rid not only of the launcher, but also of the search facility. You can keep only the bar on the upper part of the screen.

    This works great except you loose the ability to move, close, and resize windows using the mouse. I therefore recommend enabling "Effects" -> "Window Decorations" in `ccsm` and then setting up hot-keys to your favorite apps (e.g. `gnome-terminal`, `nautilus`, etc...) in "General" -> "Commands".

  • If you're using Unity 2d you just rename the file /usr/bin/unity-2d-launcher to something else, it will do the trick. You will lose search functionality too, but the menubar will work.

    Has this been renamed in 12.04? Can't seem to find it.

License under CC-BY-SA with attribution


Content dated before 6/26/2020 9:53 AM