Chrome asks for password to unlock keyring on startup

  • In Google Chrome, when I go to a login page, a window pops up asking to "Enter password for keyring 'default' to unlock". In most cases, whether I click Cancel or enter my password, the login form gets auto filled anyway.

    How do I get rid of the popup? I want it to auto login each time, not ask for my system password. The dialog box never appears for any other apps.

    You can start chrome with the command line `google-chrome --password-store=basic` so that it won't ask use the gnome keyring. See: http://code.google.com/p/chromium/wiki/LinuxPasswordStorage Because there is a workaround that is specific to Chrome, this question should not be a duplicate.

    `rm ~/.local/share/keyrings/*` Now open Chrome, if it asks you for your password, do not enter one choose Continue each time and ignore any warnings.

    Agree with @StephenOstermiller, a detailed answer is https://ubuntuforums.org/showthread.php?t=2377036&;p=13708937#post13708937

  • sebikul

    sebikul Correct answer

    9 years ago

    As described here you can set the keyring password to blank.

    Go to System/Preferences/Password and Encryption keys, right click the appropriate folder and click Change Password. Put in your old password and leave the new one blank.

    Choosing a system-wide setting to be less secure seems like a bad idea. There are better options on this page: see the libpam-gnome-keyring answer

    You don't need to mess with the wallets and keyrings at all, just disable the password store in chrome. See my answer below.

    I find that when I do this, it periodically gets reset, and I have to type in my password again. It seems to correlate with system updates, but I'm not sure. Does anyone else see this?

    Changing the system-wide keyring password to avoid one particular popup on one particular program seems pretty unsatisfactory.

  • From the manpage:

    --password-store=<basic|gnome|kwallet>
    Set the password store to use. The default is to automatically detect based on the desktop environment. basic selects the built in, unencrypted password store. gnome selects Gnome keyring. kwallet selects (KDE) KWallet. (Note that KWallet may not work reliably outside KDE.)

    The easiest way to fix that in the launcher is to copy the .desktop file to your home folder and edit it (google chrome users should copy the appropriate file):

    cp /usr/share/applications/chromium-browser.desktop ~/.local/share/applications

    Then edit the new file such that the Exec line reads like this:

    Exec=chromium-browser --password-store=basic %U

    If you have any other Chromium app installed, their .desktop files should also be in ~/.local/share/applications, edit them accordingly.

    Great, thanks! Except, the file I needed to edit was `google-chrome.desktop` rather than `chromium-browser.desktop`.

    Has to be the most elegant solution on the page -- works for me in 18.04 (pre-release).

    It works, but you need to do this every time chrome updates.

    does not work on ubuntu 19.04

    It does appear to work on ubuntu 19.04 as of this date and Chrome 74 -- there are three Exec entries: [Desktop Entry], [Desktop Action new-window] and [Desktop Action new-private-window], and it is chrome-browser.desktop. Plus, since I did this, Brave stopped keyring prompting as well. And I changed updates from Automatically to Display in Software Updates so I don't have to do play this how-to-make-simple-things-hard game again for a while.

    Edit: This action didn't affect Brave at all -- it still prompts for keyring. Just wishful thinking, I guess.

    Did not work on 19.04. still prompts for password when chromium browser launches.

    @tatsu Does `chromium-browser --password-store=basic` work when run on terminal on 19.04?

    @NormanBird even if you run it from terminal with the altered command line?

    @PietroCoelho I wonder why. Do udpates change files in "~/.local/share/applications"?

    The downside of this method is that you have to insert passwords again for different services, if you previously stored them in the keyring.

    @jarno the downside of not using the keyring is you're not using the keyring.

    You should also modify ~/.local/share/xfce4/helpers/chromium-browser.desktop, if you use chromium-browser as default Web browser in Xfce.

    Enabling `chrome://flags/#passwords-migrate-linux-to-login-db` might work for copying credentials from a keyring to '~/.config/chromium/Default/Login Data'.

    The second command didn't work for me so I did `sed -i 's/Exec=chromium-browser/& --password-store=basic/g' ~/.local/share/applications/chromium-browser.desktop`

    So annoying. And I am not even using Chrome except for testing. Thanks for the fix.

    Note that as of early-mid 2020, if you use this option, you will _not_ be able to login gmail or other google services. They will claim your browser is insecure and it won't work. This happened first for my home chrome profile a few months back, and today for my work profile. It was also the reason that I was unable to screenshare in google meet/hangouts. If this isn't happening to you yet, it's because google A/B test phases features like this in, so it will soon.

  • First make sure libpam-gnome-keyring is installed then log out and back in.

    When you open Chrome again it will ask for the password for the keyring but will give you an option to unlock the keyring every time you login. Make sure this is selected and enter your password to unlock the keyring.

    This is a better solution than the accepted answer. One shouldn't have to set an empty password just to avoid some inconvenience.

    This option is not available on Mint 16

    FYI, this option did not work for Chromium 37.0.2062.120 (running Debian 7 (Wheezy)). However, for this case, the workaround, presented in the selected answer here (passing the `--password-store=basic` option so that Chrome uses it's own password store rather than attempting to use the GNOME keyring) still works a treat!

    Not available in Mint 17 either, even with the specified package installed.

    This did not work in Xubuntu 17. no unlock the keyring option presented. same old dialog.

    This is not the right answer either. If you don't want to have a password keyring at all, just disable the Chrome password store. See my answer for more details.

    How does this even answer the question?

    I don't have _an option to unlock the keyring_. It asks for password again next time when I start the PC.

    does not work for ubuntu 19.04

    "Make sure this is selected and enter your password to unlock the keyring." Yes, but I don't want to do that after every restart.

  • You can remove this annoying message by

    1. Go to (Unity button)/Passwords and Keys
    2. On tab Passwords choose the proper key (I'd got only one, so you may need to find proper key). Right-click on it and Delete.
    3. Restart Chromium
    4. It'll ask for password --- do not type any and continue.
    5. Choose "Use unsafe storage"

    Ready for now!

    As to popups Chromium asks for password to encrypt your passwords for websites. With no password (as it said) someone will have access to your passwords having read access to some files.

  • Setting your keyring password to your login password should resolve the issue. If you completely remove the password, your keyring will be accessible without a password (i.e. by everybode who has read access).

    This is maybe the best answer for me. It will store a securely all your passwords, compared to all other answers! As an addition I would add also to un-check the option for allowing everyone to connect to the network to the security http://superuser.com/a/115737

  • First of all, I'm by no means an Ubuntu nor a security expert. I'm just an average user / programmer that wanted to install Chrome on my Ubuntu 16.04 VM running under Parallels.

    I installed Chrome, and was prompted with this annoying keyring password popup, and tried to put in my user's password to no avail.

    The solution I got to work quite accidently was to:

    1. Go to Passwords and Keys
    2. Under "Passwords" just delete the Login keyring underneath that
    3. Ubuntu now will prompt you to create the new password
    4. Now when you launch Chrome, it won't bother you with the keyring popup anymore! (Well, at least for mine, it didn't.)
  • Ubuntu 12.10

    1. Goto Keyring and password
    2. then, View>By Keyring
    3. The window will change and will show a left pane. now select Login under Passwords in the left pane. Right click & select'change password'
    4. Enter the old password and when it prompts the new password just leave it blank.

    Hope this helps

  • ## Easy Solution #####

    1.Goto Keyring and password

    2.Right Click on Login and delete.

    3.Open Chrome It will ask for enter new password leave it blank and continue. thats it

  • Edit: In fact, you might as well get rid of the keyring popup and the "your computer is old" flag at the same time.

    sudo sed -i '/^Exec=/s/$/ --disable-infobars --password-store=basic %U/' /usr/share/applications/google-chrome.desktop


    Original answer

    I made this one-liner to make disabling the password pop-up simple for when I am setting up Ubuntu VMs. I just tested it on an Ubuntu 16.04 system which had Chrome installed (not Chromium).

    sudo sed -i '/^Exec=/s/$/ --password-store=basic %U/' /usr/share/applications/google-chrome.desktop

    This command adds --password-store=basic %U to the end of any line in /usr/share/applications/google-chrome.desktop that begins with Exec=.

    Credit to Capi Etheriel, who's answer I used to develop mine.

    It might be better to copy the .desktop files to ~/.local/share/applications and edit them there. No need to use `sudo` then.

  • I wrote a script that you can run whenever Google Chrome is updated.

    Copy and paste the following script into your favorite text editor:

    #!/bin/bash
    sed -i 's/@\"/@ --password-store=basic"/g' /opt/google/chrome/google-chrome
    

    Save the file with the name fixchrome in your home directory and then run the following command to make the file executable:

    chmod +x ~/fixchrome
    

    Now, you can run the following command to fix Google Chrome whenever it is updated:

    sudo ~/fixchrome
    

License under CC-BY-SA with attribution


Content dated before 6/26/2020 9:53 AM