bash: ./install.sh: Permission denied installing intel fortran 2011

  • I am trying to install Intel Fortran Composer 2011. When I try to command ./install.sh it gives an error:

    bash: ./install.sh: Permission denied
    

    I tried some ways to get pass this.

    1. Tried; sudo ./install.sh

      sudo: ./install.sh: command not found

    2. Trying to remount the installation disk with exec permission;

      mount /media/user/IFORTRAN2011 -o remount,exec

    3. Trying to change install.sh to executable;

      chmod +x ./install.sh

    4. Tried; su -c 'install.sh'

    with root:

    bash: install.sh: command not found
    

    with user:

    Password: 
    su: Authentication failure
    

    and I am sure the password is true. (If it is the same with my user password)

    5 . I copied the disk into a folder than compressed it into

    file.tar.gz

    than extract it with

    tar xvzf file.tar.gz
    

    then tried everthing again. No luck.

    After I did chmod +x ./install.sh when I look the permissions with: ls -l ./install.sh it still gives: -rw------- 1 user user 14758 Oct 7 2010 ./install.sh

    Thanks for any help.

    The correct command is `chmod +x install.sh`.

    I tried `chmod +x install.sh` too. It did not help. Thanks for suggestion and correction.

  • There is many way to execute your script :

    • launch bash with root privilege sudo bash install.sh

    • change permissions to launch the script. However be careful, it's an installation script, it may require root privileges. So you must probably run it as root.

      chmod +x install.sh or chmod 755 install.sh

    Problem solved with `chmod -R 777 /installation_dir` command. Thanks for your help.

    @Mustafaİnanç, thank you. This command `chmod -R 777 /installation_dir` solved my problem.

    1. Right click on the something.sh file and click to properties
    2. Then click on permissions and change all access to "read and write"
    3. Then click on "allow executing file as program" (if not selected!)
    4. Close the window.
    5. Open terminal at the location of file and write:

      ./filename.sh
      
  • You have to specify the path - like mine is:

    sudo /home/humayun/Downloads/xdk_web_linux64/install.sh
    

    and it works for me. When I was typing:

    sudo ./install.sh
    

    it was giving me error: No Such file or directory. So giving the correct location is important.

  • just go and right click on the file, choose properties, go to the Permissions, and check the Execute: Allow executing file as program.

License under CC-BY-SA with attribution


Content dated before 6/26/2020 9:53 AM