How do I get resolvconf to regenerate resolv.conf after I change /etc/network/interfaces?

  • After updating /etc/network/interfaces with something very similar to below, how do I get /etc/resolv.conf to update? I tried (as root) resolver -u, service networking restart but they didn't work. I also fixed the symlink for resolv.conf and tried resolver -u again. Finally in frustration I rebooted, which did fix the problem by rebuilding /etc/resolv.conf.

    Ubuntu 12.04, 64bit server, all the latest patches installed.

    Example /etc/network/interfaces:

    iface eth0 inet static
        address 192.168.3.3
        netmask 255.255.255.0
        gateway 192.168.3.1
        dns-search example.com
        dns-nameservers 192.168.3.45 192.168.8.10
    

    What were you trying to do that resolv.conf was preventing you from doing?

  • jdthood

    jdthood Correct answer

    8 years ago

    service networking restart is not always a reliable way of down-upping all interfaces.

    The resolvconf -u command only updates resolv.conf from resolvconf's own database. You need to update the database.

    To update the database you have to call resolvconf with the -a or -d option. That happens behind the scenes when you run ifup or ifdown. So, normally, as with any other change to /etc/network/interfaces, to activate changes to the dns-* options you have to ifdown the interface in question and ifup it again. Or you can reboot.

    If you want to make changes to an interface without ifdownupping it (perhaps because you are administering the machine remotely and happen to be connected via that interface, natch) then you can achieve the same result by running resolvconf directly from the command line. This requires a bit more knowledge of resolvconf's semantics. Assume the relevant /e/n/i stanza is

    iface IIII FFFF static
        address ...
        ...
        dns-nameservers X.X.X.X Y.Y.Y.Y
        dns-search SSSS
    

    where FFFF is an address family ("inet" or "inet6").

    To activate these dns-* options you run resolvconf as follows (yes, with newlines in the string piped to resolvconf).

    echo "nameserver X.X.X.X
    nameserver Y.Y.Y.Y
    search SSSS" | sudo resolvconf -a IIII.FFFF
    

    For the stanza given in the question this would be the following.

    echo "nameserver 192.168.3.45
    nameserver 192.168.8.10
    search example.com" | sudo resolvconf -a eth0.inet
    

    Consult the resolvconf(8) manual page and the resolvconf package README file (/usr/share/doc/resolvconf/README.gz) for more information.

    "Don't do "service networking restart"; that's not a reliable way of down-upping all interfaces." Works fine for me. Good to know the clean way of doing it though.

    If you shouldn't do "service networking restart" can I suggest you don't put it in the first line of this question? When hurriedly looking for a solution, the first thing I did was copy and paste the first command I saw.

    @RobinWinslow +1 for making my day

    This answer is from the person himself who has developed `resolvconf` :)

    To restart/reread `/etc/network/interfaces`, you can do that : `ifdown eth0 && ifup eth0` ; it works even in a remote ssh session.

    does not work for me. The second nameserver (which is needed for `dnsmasq`) is ignored (for an network manager auto interface). So somewhere there are some bits missing what to do in this case.

    If dhcp settings were used on an interface such as eth0 in /etc/network/interfaces, one could initiate dhcp client and re-request IP address by running dhclient -r eth0; dhclient eth0

    @Pierre-Damien Unless there is a mistake like in `sudo ifdown eth0 && ifup eth0` (missing `sudo` on second command). Still there are more reliable ways.

  • Although the manpage isn't installed by default it's documented via the update scripts option, just run:

    sudo resolvconf -u
    
  • For those of you managing your servers remotely you can:

    1. update the dns-nameservers line in /etc/network/interfaces
    2. # ifdown eth01; ifup eth01

    Notice that this has to be on one line divided with ; (the linux command line separator). You should not even lose your current connection. The exception is making a typo in the interfaces file. If this happens ifup will fail and you will have to have physical access or another ethxx connection.

  • service resolvconf restart will regenerate /etc/resolv.conf file without much fuss.

    I get `Failed to restart resolvconf.service: Unit resolvconf.service not found.`

    command completed however not regenerated `/etc/resolv.conf` on ubuntu server 14.04

    On Ubuntu 18.04, there was no fuss, like you said, but the file was not regenerated either... Be aware of this, make a backup before following instructions.

  • This answer is similar to the one above but uses the questions example configuration to answer the question. Plus this explains why both commands are necessary.

    Edit /etc/network/interfaces:

    iface eth0 inet static
        address 192.168.3.3
        netmask 255.255.255.0
        gateway 192.168.3.1
        dns-search example.com
        dns-nameserver 192.168.3.45
        dns-nameserver 192.168.8.10
    

    These changes will not take place unless you reboot or reload the configuration file:

    In order to update the interfaces file live it is necessary to run the following command:

    echo "nameserver 192.168.3.45
    nameserver 192.168.8.10
    search example.com" | sudo resolvconf -a eth0.inet
    

    This allows an update to the interface without a reboot or reloading.

    However, the above command changes will be lost after a reboot if the changes in the /etc/network/interfaces are not made.

    By the way the last answer from BDenis in this list actually works in place of the last command by parsing the /etc/network/interfaces file and piping those lines into the command sudo resolvconf -a eth0 It's actually half the answer and a really good example of inline sed parsing. If you want to see how it does this just run the first part of the command and watch it parse the /etc/network/interfaces file and spit out all the necessary information you need to run the sudo resolvconf -a eth0 command:

    sed 's/#.*$//' /etc/network/interfaces | grep dns- | sed 's/dns-//g'
    

    Notice this would produce the same out put as the command:

    echo "nameserver 192.168.3.45
    nameserver 192.168.8.10
    search example.com"
    

    Provided that the /etc/network/interfaces file is configured with this information:

    iface eth0 inet static
        address 192.168.3.3
        netmask 255.255.255.0
        gateway 192.168.3.1
        dns-search example.com
        dns-nameserver 192.168.3.45 
        dns-nameserver 192.168.8.10
    

    Sadly cannot use that. My interface is managed by network manager and DHCP, so adding it to `/etc/network/interfaces` is not a valid option in that case. (Ubuntu 14.04)

  • Simple answer :

    Just install resolvconf. apt install resolvconf

    After that, ifup eth0 updates the dns in etc/resolv.conf, according to the dns-nameservers line in /etc/network/interfaces.

    unknown interface. Everybody really knows how to obfuscate the details here ... I think we should aim to containerize all the commands. Full script for each, no prose.

  • On 18.04, the following works reliably (run as root):

    systemctl stop networking
    ip address flush dev <device> # just to be safe
    systemctl start networking
    

    Important: Make sure you have package resolvconf installed.
    It doesn't seem to be by default, and without it some (!) changes from /etc/network/interfaces are silently ignored (e.g. dns-*).

  • This worked for me:

    sed -re '/nameservers|dns-search/ !d' -e 's/dns-nameservers/nameserver/' -e 's/dns-search/search/' /etc/network/interfaces  | resolvconf -a eth0.inet && resolvconf -u
    

    Adjust accordingly.

  • On desktop version of Ubuntu 18.04, where there's no service networking, and resolvconf isn't installed by default, I've succeeded in regenerating resolv.conf by restarting network-manager:

    sudo service network-manager restart
    
  • Also you can try this command:

    cat /etc/network/interfaces |sed 's/#.*$//'|grep dns-|sed 's/dns-//g'|sudo resolvconf -a eth0.inet
    

    Can you explain why this command should work?

    This does not work correctly if you have more than one nameserver IP in the line `dns-nameserver IP1 IP2`. The line must then be repeated in `resolv.conf`, but isn't.

    Moreover, `/etc/network/interfaces` uses `dns-nameservers` (notice the `s` at the end) while `resolvconf` uses `nameserver`. The command does not deal with it. And even if everything was correct, the pipeline `sed | grep | sed` definitely wouldn’t be the most efficient way.

License under CC-BY-SA with attribution


Content dated before 6/26/2020 9:53 AM