GPG error: The following signatures couldn't be verified because the public key is not available

  • Possible Duplicate:
    How do I fix the GPG error “NO_PUBKEY”?

    after sudo apt-get update I get this error:

    W: GPG error: http://archive.hivemind.me all Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 3C962022012520A0
    

    Hi! I tried, but no success, look: .... $sudo apt-key adv --keyserver archive.hivemind.me --recv-keys 3C962022012520A0 Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver archive.hivemind.me --recv-keys 3C962022012520A0 gpg: requesting key 012520A0 from hkp server archive.hivemind.me ?: archive.hivemind.me: Connection refused gpgkeys: HTTP fetch error 7: couldn't connect: Connection refused gpg: no valid Open

    The website appears to be either down or misconfigured, I can't get to it either.

    You can check this SO thread for solution. Link to related site

  • karthick87

    karthick87 Correct answer

    10 years ago

    Run the following in your terminal,

     sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 3C962022012520A0 
     sudo apt-get update
    

    References: How do I fix the GPG error "NO_PUBKEY"?

    You need to replace the key (3C962022...) with the one that is displayed in the error message in the terminal.

    Me too! I'll have to read up on this.

    How do you achieve this on OSX?

    If you get a `keyserver timed out` error, do `sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3C962022012520A0`

    @arjun I received a `gpg: keyserver receive failed: Server indicated a failure`, but using this command it worked for me. Thank you!

  • When you add a third-party repository, you should also add its key to your system. The public key is a string which identifies that certain repository. You can find some more information on this and how to add the key here.

License under CC-BY-SA with attribution


Content dated before 6/26/2020 9:53 AM