How to change mouse speed/sensitivity?

  • I am on an Asus Zenbook UX32VD in Ubuntu 12.10. Both in 12.04 and 12.10 I haven't been able to change the mouse speed (i.e. the "sensitivity" in the mouse/touchpad dialog). I can change the slider, but nothing changes.

    This is a big problem for me, since the mouse speed is somewhat slow. Any suggestions?

    The problem is both for the touchpad and mouse.

    I dont have this laptop - so hence this comment. Maybe this Q&A can help - http://askubuntu.com/questions/130217/how-to-edit-synaptics-touchpad-values-in-ubuntu-12-04-no-xorg-conf-file . If you type `synclient` you have some parameters such as `MinSpeed`, `MaxSpeed` & `AccelFactor` that you can play with. Good luck.

    I have installed LXInput from Softwarecenter. It's for LXDE but works also unter Unity. Anja

  • First we need to identify the input device ID to change the speed/sensitivity. Open a terminal and run this command:

    xinput --list --short
    

    output:

    [email protected]:~$ xinput --list --short
    
    Virtual core pointer
    
    ↳ SynPS/2 Synaptics TouchPad                id=11   [slave  pointer  (2)]
    
    ↳ Logitech USB RECEIVER                     id=12   [slave  pointer  (2)]
    

    My pointing devices are a Logitech USB RECEIVER and a Synaptics TouchPad. To list out device properties:

    xinput --list-props "SynPS/2 Synaptics TouchPad"
    

    EDIT:

    Another option: xinput --list-props 11 as 11 is the number that is shown above in its parent property (SynPS/2 Synaptic TouchPad).

    Now reduce it's property values to suit your need:

    Device Accel Constant Deceleration (267):   2.500000
    

    using this command:

    xinput --set-prop "SynPS/2 Synaptics TouchPad" "Device Accel Constant Deceleration" 1.5
    

    EDIT:

    Another option: xinput --set-prop 11 267 1.5 where 11 is the device, just like from above, 267 is the id of the device property (Device Accel Constant Decleration) as you can see when device 11 is being listed all of properties being attached, and finally 1.5 is your desired speed.

    You may have to play around with this number a bit to set it exactly as you need.

    If you need to set this value automatically every time Ubuntu starts then:

    create a .sh file

    #!/bin/sh
    
    xinput --set-prop "SynPS/2 Synaptics TouchPad" "Device Accel Constant Deceleration" 1.5
    

    change the file to executable :

    chmod +x
    

    and Put this in the start-up applications list.

    Source : Configuring Mouse Speed manually

    I now have the same problem for my wireless logitech mouse with unified reciever. I can change the speed in the same way, but max speed (1) is way too slow! Any suggestions?

    Try increasing the acceleration property. <"Device Accel Velocity Scaling" 5> . I also have a Logitech wireless mouse and i can't see any direct speed property. all i got is acceleration and deceleration. Please tell what speed property your device is showing and also try to increase the value of speed beyond 1 and see if that works..

    I made the value 0.5 on ThinkPad e530c with Debian 8 and it's working sweetly :)

    Doesn't work for me somehow. The .sh-file is being executed. Command works manually in console after start. Looks like the mouse is being detected after the .sh-file has been executed.

    In that case you might have to trigger the script after the device is detected. Not sure how to do that. There must be some listener option though.

    Linux mint 18, Logitech 510, xinput says "property 'Device Accel Constant Deceleration' doesn't exist, you need to specify its type and format"

    is there anyway to increase mouse speed w/o using acceleration?

    @chovy you can try hacking with Coordinate Transformation Matrix, prop 144, (something like `xinput set-prop ?? 144 2 0 0 0 2 0 0 0 1`) but you will loose precision

    This option does not suit gamers. (Admittedly, I game on Windows, but I just dislike mouse acceleration.)

  • Ubuntu 12.10 64-bit, Logitech cordless TrackMan

    xinput did nothing for me.

    xset q
    

    to check settings

    xset mouse 3 0
    

    This sets the acceleration to 3 and the threshold to zero. Not great settings but better than before.

    If you want to use fractional value, you can enter fraction (i.e. 3/2) instead of floating point number.

    The man page says the settings will be lost on logout/reboot.

    If you want to use fractional value, you can enter fraction (i.e. 3/2) instead of floating point number. It's weird, but it works.

    hmm, so what is the fastest speed that xset can do?

    Thank you I was getting quite annoyed at my inability to manipulate bodhi linux mouse speed

  • The above mentioned "Device Accel ..." options do not exist on my machine. Lenovo T440s running Ubuntu 18.04

    Instead, I have success using these:

    xinput --set-prop "TPPS/2 IBM TrackPoint" "Coordinate Transformation Matrix" 0.5 0 0 0 0.5 0 0 0 1
    

    The original "Coordinate Transformation Matrix was 1 0 0 0 1 0 0 0 1 and I have now half the speed, which is slow enough for me.

    With this syntax, we can adjust horizontal and vertical speed separately.

    Thanks for this. I have successfully used this to speed up my Logitech K520 mouse, so I wanted to mention that it appears to work for Logitech mice too. Oddly, the right-most number seems to slow down vertical scrolling at higher numbers, and speed up at lower ones.

    This approach worked well with a Microsoft Microsoft Wireless Optical Mouse, where the mouse was too sensitive to use while walking on a treadmill.

  • You can use these scripts to set the touchpad and mouse speed each systemstart:

    #!/bin/sh
    TP=$(xinput --list --short|grep -i touchpad|cut -f 1 | cut -d" " -f 5-|sed 's/\s\+$//g')
    xinput --set-prop "$TP" "Device Accel Constant Deceleration" 1.5
    xinput --set-prop "$TP" "Device Accel Velocity Scaling" 10
    

    For me, I think 1.5 and 10 are suitable values for the touchpad.


    I use a Logitech usb mouse too.
    So for a Logitech mouse use this script:

    #!/bin/sh
    MOUSE=$(xinput --list --short|grep -i Logitech| cut -f 1|cut -d" " -f 5-|sed 's/\s\+$//g')
    xinput --set-prop "$MOUSE" "Device Accel Constant Deceleration" 1.2
    xinput --set-prop "$MOUSE" "Device Accel Velocity Scaling" 10
    

    For me, I think 1.2 and 10 are suitable values for the mouse.

    I created a project on Github: https://github.com/rubo77/mouse-speed

  • I've fine-tuned deceleration by closing my eyes, before moving pointer to a certain place on the screen. After 5 adjustments, now my mouse moves that much as I'm expecting.

    That's the line I'm using right now:

    xinput --set-prop "Bluetooth Mouse M557" "Device Accel Constant Deceleration" 2.3

  • Running sudo xset m 1 1 worked for me. My mouse speed now behaves in a normal behaviour like in Windows platform.

  • I used the 'simple' profile to increase the mouse resolution without acceleration.

    #!/bin/bash
    
    device="Dell Dell USB Optical Mouse"
    resolution_percent="241" # Greater than 100, use constant deceleration otherwise with profile -1. 
    
    xinput set-prop "$device" "Device Accel Profile" 4 # Simple profile with threshold 0 allows constant scaling up
    xinput set-ptr-feedback "$device" 0 "$resolution_percent" 100 # Set threshold to 0 and acceleration to $resolution_percent/100
    

    You'll have to modify the script by using your particular device name. You can look that up by running xinput without arguments. Also the script has to be run each time the mouse is connected or when you start the system.

  • Just want to add to the previous answers that it's possible that there won't be "Device Accel Constant Deceleration" property. For example, I don't have it for Logitech G600 in Kubuntu 17.04. But there is "Coordinate Transformation Matrix" which is even more power

  • As mentioned by others acceleration is not the same as speed. Until recently I used the Coordinate Transformation Matrix setting to scale the mouse velocity and disabled mouse acceleration with xinput. But this comes with its own issues - I had issues in Blender when doing mouse middle button drags to rotate the scene - The cursor was jumping as soon as I released the button. There is an open issue.

    But I found a way to directly set the DPI of the mouse. It is possible to create a setting file here:

    sudo vim /etc/udev/hwdb.d/50-mouse-dpi.hwdb
    

    With the following content - Replace <name-of-the-device> with the name shown in xinput (e.g. "Logitech G700s Rechargeable Gaming Mouse").

    mouse:*:name:<name-of-the-device>:
     MOUSE_DPI=320
    

    To apply the settings execute

    sudo systemd-hwdb update && sudo udevadm trigger
    

    Repeat until you find a DPI value which makes you happy.

    I wasn't able to get this to work with a Logitech mouse

  • My Logitech MX518 mouse was too slow on Ubuntu 18.04. I tried to set Accel speed prop to max (1), but it did not speed it enough.

    After some more searching, found lomoco (Logitech Mouse Control) and installed it with

    sudo apt install lomoco
    

    The man page is here http://manpages.ubuntu.com/manpages/xenial/man1/lomoco.1.html

    The manual is good, but for a restless soul, this is what I did:

    lomoco --scan
    

    Got this as one of the output lines. c051 is the product ID.

    002.004: 046d:c051 MX518 Optical Mouse (M-BS81A) Caps: RES
    

    Then set the sensitivity

    sudo lomoco -p c051 --1600
    

    And got a fast mouse.

License under CC-BY-SA with attribution


Content dated before 6/26/2020 9:53 AM