Proper fstab entry to mount a samba share on boot?

  • I am a little confused on the proper fstab entry for a samba share in Ubuntu 12.04

    • I can get the drive to mount manually by using:

      sudo mount -t cifs // /mnt/homeserver -o username=jon,password=password
    • So I tried putting this in fstab:

      // /mnt/homeserver cifs username=jon,password=password,iocharset=utf8,mode=0777,dir_mode=07‌77 0 0
    • Which gives me this error in syslog:

      kernel: [ 2217.925354] CIFS: Unknown mount option mode
      kernel: [ 2217.936345] CIFS VFS: default security mechanism requested.  The default security mechanism will be upgraded from ntlm to ntlmv2 in kernel release 3.3
    • This guide says to use smbfs although I believe smbfs is deprecated?

    What is a common fstab configuration for a samba share in Ubuntu 12.04?


    Using the accepted answer below I was initially getting this error message (from dmesg):

    [   45.520883] CIFS VFS: Error connecting to socket. Aborting operation
    [   45.520990] CIFS VFS: cifs_mount failed w/return code = -115

    although it turns out this was due to network connectivity issues, and not related to improper fstab entry.

    You could try using the server computer's IP address instead of its name.

    That means you'll have to pass the password on the file? Is that a way to make the password secure?

    You can use a .smb credentials file with only root permission as @russnash suggests below.

    just tried your solution, but then i type sudo moun -a i get a error: [mntent]: line 13 in /etc/fstab is bad this is what i have typed /etc/fstab: //\ -\ Installation /media/Service cifs credentials=.smbcredentials,uid=shareuser,gid=sharegroup 0 0 the reason for \ is that i read somewhere that if there where spaces in the folder then i should type \ to indicate that its a space.. even tried "Service - Installation"

  • russnash

    russnash Correct answer

    8 years ago

    I've been through exactly this same issue this morning with 12.04 and here's how I got it working:

    Install cifs-utils Install smbfs (even if you already have Samba and related packages installed):

    sudo apt-get install cifs-utils

    Edit /etc/fstab and add your entry:

    //server/share /pathto/mountpoint cifs credentials=/home/username/.smbcredentials,uid=shareuser,gid=sharegroup 0 0

    Create the .smbcredentials file in your home directory:


    Make sure you secure your ~/.smbcredentials file:

    chmod 0600 ~/.smbcredentials

    Finally, test the mount with:

    sudo mount -a

    ...and you should be good to go!

    I can't write to the share, even though the same user can when logging in with Windows. Is this a read only mount?

    `smbfs` has been replaced with `cifs-utils`, other than that the instructions work for me too.

    I ran into an error ("bad option: uid=my_username"). I got past it by removing the uid & gid options in fstab.

    @reg The correct option is `user` when the username is given (similarly `group`) since `uid` is for the numerical user id.

    As an aside, the Ubuntu wiki has a full page on mounting samba shares including troubleshooting stuff.

    //server/share /pathto/mountpoint cifs password=

    The reason why you should put your credentials into a file is because /etc/fstab is readable by everyone and so are your passwords in it. Source:

    "username=domain/user" in the credentials file worked fine for smbclient, but @russnash's idea here of splitting it out to a separate line finally fixed it for me. THANK YOU!

  • Your initial problem is in the option mode, as syslog says in the first line. What you probably meant was file_mode, see man mount.cifs for more information.

    The credential approach mentioned by Eliah is indeed better than using username and password, but I don't think it interferes with the other options like file_mode or dir_mode.

License under CC-BY-SA with attribution

Content dated before 6/26/2020 9:53 AM