cmake fails with "CMake Error: your CXX compiler: "CMAKE_CXX_COMPILER-NOTFOUND" was not found."

  • [email protected]:~/Downloads/akonadi-googledata-1.2.0/build$ cmake ..
    -- The C compiler identification is GNU
    -- The CXX compiler identification is unknown
    -- Check for working C compiler: /usr/bin/gcc
    -- Check for working C compiler: /usr/bin/gcc -- works
    -- Detecting C compiler ABI info
    -- Detecting C compiler ABI info - done
    CMake Error: your CXX compiler: "CMAKE_CXX_COMPILER-NOTFOUND" was not found.   Please set CMAKE_CXX_COMPILER to a valid compiler path or name.
    CMake Error at /usr/share/cmake-2.8/Modules/FindKDE4.cmake:98 (MESSAGE):
      ERROR: cmake/modules/FindKDE4Internal.cmake not found in
      /home/jonquil/.kde/share/apps;/usr/share/kubuntu-default-settings/kde4-profile/default/share/apps;/usr/share/kde4/apps
    Call Stack (most recent call first):
      CMakeLists.txt:6 (find_package)
    
    
    CMake Warning (dev) in CMakeLists.txt:
      No cmake_minimum_required command is present.  A line of code such as
    
        cmake_minimum_required(VERSION 2.8)
    
      should be added at the top of the file.  The version specified may be lower
      if you wish to support older CMake versions for this project.  For more
      information run "cmake --help-policy CMP0000".
    This warning is for project developers.  Use -Wno-dev to suppress it.
    
    -- Configuring incomplete, errors occurred!
    

    With autotools I get this:

    [email protected]:~/Downloads/akonadi-googledata-1.2.0/build/build$ autoreconf -i -f
    Can't exec "libtoolize": No such file or directory at /usr/bin/autoreconf line 196.
    Use of uninitialized value in pattern match (m//) at /usr/bin/autoreconf line 196.
    autoreconf: `configure.ac' or `configure.in' is required
    

    what does `which g++`say? Obviously there is no working c++ compiler on the system.

    It doesn't say anything. I have GCC installed if that helps.

  • Install build-essential Install build-essential if you haven't done so already. You can install it in the Software Center or with:

    sudo apt-get update && sudo apt-get install build-essential
    

    solved my problem!

  • gcc does not contain g++, these are different packages. Install g++ Install g++:

    apt-get install g++
    

    Now I'm getting this: CMake Error at /usr/share/cmake-2.8/Modules/FindKDE4.cmake:98 (MESSAGE): ERROR: cmake/modules/FindKDE4Internal.cmake not found in /home/jonquil/.kde/share/apps;/usr/share/kubuntu-default-settings/kde4-profile/default/share/apps;/usr/share/kde4/apps Call Stack (most recent call first): CMakeLists.txt:6 (find_package)

    you are missing a build environment, it's more than just compilers, you need libraries and so on. Take a look here to find out what you need: https://help.ubuntu.com/community/CompilingEasyHowTo

    I KNEW there was a package I could install in Ubuntu that would give me all the necessary packages for compiling, I just couldn't remember the name of it. Thanks!

    I'm still getting the same error though. :(

    The error messages hint's at kde - kde development is not included in build-essential. Don't know if there is a meta package for this.

    Could kde-workspace-dev be it? How about kdelibs5-dev?

    I went ahead and installed them both and now it's going smoothly. Still got some unmet dependencies but I should be ok from here... if not I'll post here again!

    I thought I got all my dependencies but now when I type "make" I get this: /usr/local/bin/msgfmt: error while loading shared libraries: libgettextsrc-0.18.so: cannot open shared object file: No such file or directory make[2]: *** [po/bg/akonadi_gcal_resource.gmo] Error 127 make[1]: *** [po/bg/CMakeFiles/pofiles.dir/all] Error 2 make: *** [all] Error 2

    I have libgettext installed btw. I also have libgettext-ocaml-dev installed.

    Ok, it was a package actually called libgettextsrc. I had to get the RPM version and convert it using Alien. I now have akonadi-google installed on my system. Thanks for all the help! I would vote you a few more times if I could. :D

  • I am aware that this is "Ask Ubuntu", but if someone with Fedora would meet this problem, the following helped me:

    sudo dnf install gcc-c++
    

    Your are correct in terms of the purpose of this particular forum. Please note that questions - and answers - relating to distros other than Ubuntu Linux should be posted at https://unix.stackexchange.com

License under CC-BY-SA with attribution


Content dated before 6/26/2020 9:53 AM