How to install NVIDIA.run?

  • I have a Nvidia Ge force Ge6150 SE graphics card. I am running ubuntu 12.04. When I try to install the .run file it fails. It shows the message like this:

    I tried to install it after uninstalling the old driver.still same message. Here is the log file:

    nvidia-installer log file '/var/log/nvidia-installer.log'
    creation time: Mon Jun 11 05:46:17 2012
    installer version: 295.53
    
    PATH: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
    
    nvidia-installer command line:
        ./nvidia-installer
    
    Using: nvidia-installer ncurses user interface
    -> The file '/tmp/.X0-lock' exists and appears to contain the process ID '1062' of a >runnning X server.
    ERROR: You appear to be running an X server; please exit X before installing.  For >further details, please see the section INSTALLING THE NVIDIA DRIVER in the README >available on the Linux driver download page at www.nvidia.com.
    ERROR: Installation has failed.  Please see the file '/var/log/nvidia-installer.log' >for details.  You may find suggestions on fixing installation problems in the README >available on the Linux driver download page at www.nvidia.com.
    

    but no such file is shown in the process manager.

    Does installing the nvidia-current package in ubuntu with apt-get not work with your card? Why are you trying to install that version of the driver, rather than the supported version packaged for ubuntu 12.04?

    It has problems with my card.It conflicts with unity.Glitches in video playback .Nvidia Current is still 295.40!It do not give me the resolution 1440*900

    Don't use the `.run` file. Just `sudo add-apt-repository ppa:graphics-drivers/ppa`. The latest drivers will appear in "Software & Updates --> Additional Drivers".

  • As the error states, you are still running an X server. This error occurs when you try to install the Nvidia .run files while logged in.

    Make sure you are logged out.

    1. Hit Ctrl+Alt+F1 and login using your credentials.
    2. kill your current X server session by typing sudo service lightdm stop or sudo lightdm stop
    3. Enter runlevel 3 by typing sudo init 3
    4. Install your *.run file.
      1. you change to the directory where you have downloaded the file by typing for instance cd Downloads. If it is in another directory, go there. Check if you see the file when you type ls NVIDIA*
      2. Make the file executable with chmod +x ./your-nvidia-file.run
      3. Execute the file with sudo ./your-nvidia-file.run
    5. You might be required to reboot when the installation finishes. If not, run sudo service lightdm start or sudo start lightdm to start your X server again.
    6. It's worth mentioning, that when installed this way, you'd have to redo the steps after each kernel update.

    I only see a blank, black screen when trying to access the tty terminals. How should I go about installing the drivers?

    This made my laptop unusable. I boot successfully into the login screen, but when I login to any account, I see a black screen for a second and I am back at the login screen... any idea what's going on or how to resolve it? :(

    This happened to me on my GT220 card, updating to nvidia 340. Apparently, the card is not supported by the latest driver. You may try going down a version or two until you have a usable desktop. Good luck!

    "Enter runlevel 3 by typing sudo init 3 and install your *.run file" can you please clarify how to install the .run file?

    Once you've managed to enter runlevel 3, you can simply type and execute. The installer will guide you through the process.

    Notice that runlevel `3` is the same as runlevel 2-5 in all Debian distros (including Ubuntu), see: Debian and Ubuntu Linux Run Levels. This means that you need to `sudo service lightdm stop` after that you enter to runlevel `3`. In our case, it seems redundant to enter to runlevel `3`, isn't it?

    They are not the same. More like similar because they are all multi-user modes. #2 has a graphical display manager, whereas #3 does not. Read the part about `#telinit 3' somewhere near the bottom.

    Great advice to kill your machine...

    If you have a black screen you might have a terminal prompt out of view, type enter a handful of times to make sure you still don't have a terminal session open but you just can't see it.

    This killed my Ubuntu installation after stopping the lightdm service. Now I have another problem to solve. Why is this the most upvoted answer?

    @Jabberwockey A few things have changed since this answer was posted but this is still the correct process. More likely you installed the wrong Nvidia driver for your card or a corrupted file. Ask a new question with the specifics.

    @Jabberwockey, how did you solved your installation issue? I follow these instructions and it crashed my installation too.

    You can restart from terminal with `shutdown -r 0`

    I couldn't get any of the `.run` files from Nvidia's site to work (they would install but driver was broken). Using the `graphics-drivers` PPA instantly worked for me, as detailed in this answer: https://askubuntu.com/questions/61396/how-do-i-install-the-nvidia-drivers/61433#61433. `nvidia-390`.

    for some reason service lightdm stop doesn't stop it. had to manually kill it.

    If your install for some reason has lightdm permanently disabled on reboot (causing login issues), edit the conf at bootup with 'e', find the line starting with 'linux', and append a '3' to the end of the line. This should start you up straight into terminal, where you can then restart the lightdm.

    Works on `Ubuntu 18.10`. Thanks! Additionally, I used this link https://askubuntu.com/questions/842256/nvidia-driver-install-ubuntu-16-04 and during installation say yes to all installation steps (nvidia-xconfig utility, 32-bit OpenGL libraries, DKMS support)

    I do not undestand, how do I do anything when I am not logged in

    @user1111929 I also the same problem. Did you find any way to resolve it? Or just reinstall Ubuntu?

    @Hossein This was 3.5 years ago, I do not remember sorry. But given the 18 upvotes on my comment, I suspect we're not the only ones.

  • I installed latest nvidia drivers by this method:

    sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
    sudo apt-get update
    sudo apt-get install nvidia-current
    

    It is working fine with unity 3d. Thanks to all.

    it's not clear if this gets around the problem of trying to install the driver while an X server is running.

    This doesn't fix the X server issue when trying to install the .run file, but it does offer another way to install/update to the latest nvidia drivers packaged for the unbuntu distro.

    The driver this serves up is many versions outdated. Is there a way to get the actual current version through apt-get?

    I strongly **not** recommend this method. It made my X server to refuse to start on system start, I had to remove it on console mode. It seems that those drivers are now very outdated and not updated anymore.

    I strongly recommend this console method (don't use the website or .run files at all) as confirmed here: http://askubuntu.com/a/624967/662072

    Although this method works with unity, it will crash when installing driver with a gnome desktop

  • Add the --no-x-check flag when you run this in the terminal:

    sudo ./NVIDIAxxxx.run --no-x-check
    

    `[email protected]:~/Downloads$ sudo ./cuda_8.0.44_linux.run --no-x-check Unknown option: no-x-check`

    This doesn't resolve the issue on 16.04 for me. Driver installation still detects X server running and fails.

    From the docs: `--no-x-check Do not abort the installation if nvidia-installer detects that an X server is running. Only under very rare circumstances should this option be used.`

    @marcelocra , Where did you find such document? Could you attach the link?

    The ./NVIDIAxxxx.run command is a bash script. I believe the documentation was inside of it. If that's really the case, try `vim ./NVIDIAxxxx.run` (sorry, I don't remember anymore, but since I didn't link it, that is probably correct).

  • I had the same problem installing the driver for an old GeForce 9800 GT in Ubuntu 14.04-2. It was the NVIDIA-Linux-x86_64-340.76.run

    I switched to the the tty1 using Ctrl+Alt+F1 and also stopped the service lightdm and when running the executable got the same error .

    What I did to solve the problem was navigate to the /tmp folder and erase the .X0-lock file.

    You will only see it listed if you use ls -la as it is a hidden folder by default(that is why it has a dot in front of the name)

    cd /tmp
    rm -rf .X0-lock
    

    After erasing that folder and executing the NVIDIA-Linux-x86_64-340.76.run it installed just fine.

    Did this work? Why the answer everyone complains in the comments is the most upvoted?

  • This instructions Works great under ubuntu server 12.04 with ubuntu desktop for nvidia 8400GS PCI 512MB too just need to unistall all previous versions of default versions under ubuntu like 173 etc or any other before installing or there will be conflict or crash. Follow this tread instructions + read me install info from your card model example in my case latest driver version 319.23, see link below:

    http://us.download.nvidia.com/XFree86/Linux-x86/319.23/README/installdriver.html

    please provide a summary of the steps required in addition to posting a link

  • Ubuntu 16.04 with Quadro 4000 confirmed that this method work:

    sudo apt-get update
    sudo apt-get install nvidia-375
    

    Note that I don't use nvidia-current as I downloaded the run file from NVIDIA and its version is 375.66

    This even worked for linuxlite 4.4

  • What worked for me:

    sudo killall Xorg
    

    and I had to run this multiple times, until I got a message saying

    Xorg: no process found.

    Then I am sure X server is stopped.

  • I got this error when stopped X server to install CUDA. My system is Ubuntu 16.04 and i installed CUDA 8.0 from runfile. I fixed it just by upgrading my system. When the error message appears, press Ctrl + Alt + F1, log in with your account, and then run the two following commands:

    sudo apt-get update
    

    and

    sudo apt-get dist-upgrade
    

    Afterward, sudo reboot it should be working fine.

  • nvidia-installer log file '/var/log/nvidia-installer.log' creation time: Mon Jun 11 05:46:17 2012 installer version: 295.53

    PATH: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
    
    nvidia-installer command line: ./nvidia-installer
    

    Using: nvidia-installer ncurses user interface -> The file '/tmp/.X0-lock' exists and appears to contain the process ID '1062' of a >runnning X server. ERROR: You appear to be running an X server; please exit X before installing. For >further details, please see the section INSTALLING THE NVIDIA DRIVER in the README >available on the Linux driver download page at www.nvidia.com. ERROR: Installation has failed. Please see the file '/var/log/nvidia-installer.log' >for details. You may find suggestions on fixing installation problems in the README >available on the Linux driver download page at www.nvidia.com.

    Killing X Server

    As mentioned in the log, process ID 1062 is the reason X server is running.

    Kill 1062
    

    will kill the process and after that installation of NVIDIA driver will run smoothly.

    `Kill [ID]` killing process ID is logging me out and have to login again. Is X server related to logged in UI?

  • I had the same problem with ubuntu 18.04, so in order to solve this problem, I deleted lock file.

    cd /tmp
    ls -a
    sudo rm -rf .X1-lock
    

    Then you can install your Nvidia driver. Hope it will help ubuntu 18.04 users this is copied from @Juan P

License under CC-BY-SA with attribution


Content dated before 6/26/2020 9:53 AM