Headphone jack not working?

  • I have a Dell Studio XPS 1647 and headphones do not work (though , internal speakers work like a charm) , I have dual boot Windows 7 and headphones work perfectly fine ...

    I also tried -adding in options snd-hda-intel model=eapd probe_mask=1 position_fix=1.

    I've experienced this with Oneric Ocelot and the latest Precise Pangolin (LTS).

    // , Please add output for the following command: `$ lspci | grep Audio`. This will show your audio chipset, among other things, e.g. `00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)`

  • Finally got Headphones to work ! Follow this ----- (Dell)

    This is it :


    Run the following command into the Terminal:

    gksudo gedit /etc/modprobe.d/alsa-base.conf
    

    Scroll down and add these lines to the end of the file:

    # Keep snd-pcsp from being loaded as first soundcard
    options snd-pcsp index=-2
    alias snd-card-0 snd-hda-intel
    alias sound-slot-0 snd-hda-intel
    options snd-hda-intel model=dell-m6-amic
    

    Then, save , reboot and test sound using headphones and speakers.

    This is always the comment that I end up finding that fixes my sound after I reinstall my laptop. So thanks, and hi future me :-)

    I didn't have to reboot. Instead run `sudo alsa force-reload` and then unplug and insert the headphone.

    didn't work my dell xps 13, 9360 running ubuntu 16.04 sound comes from both speakers and headphones

    Worked like a charm on my ThinkPad P50 with Ubuntu 16.10

    In my case, this only detects the headset when it is plugged while rebooting. Before the last update, ubuntu detected the plugin action and asked you whether this where headphones, mic or headset. How can I get that behaviour?.

    Worked for Dell XPS 13 with Ubuntu 16.04. Thank you!

    I don't have file /etc/modprobe.d/alsa-base.conf on Linux Mint (Ubuntu), Dell XPS

    Didn't work on my hp spectre 360, running Ubuntu 18.04

    Can I use this for my iMac?

    I agree with @tsimon . This comment is still relevant and worked on both my laptops, Lenovo 330s and MSI P63.

  • I've tried all these responses. Here is the ONLY way that worked for me (and it was remarkably quick... after spending hours on all the other suggestions!). Go into Terminal, and simply key this in:

    $ alsactl restore
    

    And that's that! :)

    Did you reboot after running this?

    No, but I do need to close and restart all the programs using audio - or in the case of a tab in a browser (ie, a youtube clip or something), reload the tab.

    Ok. I had to do a full shutdown and not a restart. Only then did it work for me. I'm using an ASUS K56--30

    Just this worked for me on an ASUS F555U. Thank you.

    worked for me on dell xps 16.04 (after upgrade from 14.04)

    This worked on my XPS 13 9360 (Ubuntu 16.04.2). Headphones started working immediately after that. My unit looses the headphone irregularly.

    That worked with me (HP Probook i7-6500)

    This worked perfectly.

    Also worked instantly on a Dell Latitude 3580.

    Work for me on acer swift 3. Funny that I did not need to restart or anything, sound was instantly turn on as soon as I hit enter.

    I cannot confirm that this is the only fix that works, but it did work for me, and is definitely a very simple fix. Although it fixed the sound of a midi keyboard through qsynth to the headphones, the ubuntu build-in audio test still does not work.

    This didn't work for me on Ubuntu 18.04 with an hp spectre 360. I got an error when running the command: `alsactl: state_lock:125: file /var/lib/alsa/asound.state lock error: File exists alsactl: load_state:1683: Cannot open /var/lib/alsa/asound.state for reading: File exists`

    @Limok Palantaemon Use `sudo alsactl restore` and it should work.

    @MosheRabaev I tried it. The command no longer gives the "Cannot open" error, however unfortunately it doesn't fix the problem :P. Thanks for the help though. I've been reading up on my issue, and basically it seems like it's something specific to my line of laptops (HP x360). Several people much more knowledgeable than me have been trying to fix it for years, apparently it's something very "close the hardware" and way too technical for me. To others who have the same problem, check out this thread (but leave your hopes at the door ): https://bugzilla.kernel.org/show_bug.cgi?id=189331

    In my case (Ubuntu 18.04.1 LTS on Dell Latitude E5440) the problem was skypeforlinux. The headphones stopped working after having a videocall. After removing skypeforlinux, they worked again.

    It worked for me!

    This worked for me too!

    Just upgraded to 5.0 via the 18.04.3 HWE opt-in --- broke my headphones, and this saved the day~! Thank you very much!!

    I had only one ear working.. used this command and it worked like a charm (not sure why), but it worked.

    @PepeLebuntu Worked for me in Linux Mint-Tina. Thanks

    Works without reboot. This shold be the accepted answer.

    Year 2020, still works :)

    What should be the expected output of this command?

    It works better after a complete shutdown.

    Works once in hp spectre x360 nvidia but not anymore

    ubuntu studio 20.04 just installed in a dell XPS 15, and found this problem. You're my hero!

  • I had the same problem. Following these instructions got my headphones working.

    Open the terminal and enter the following commands:

    cd /usr/share/pulseaudio/alsa-mixer/paths/
    sudo cp analog-output-headphones.conf analog-output-headphones.bak
    sudo nano analog-output-headphones.conf
    

    Look for the section called [Element Speaker] and change it so that it looks like this:

    [Element Speaker]
    switch = on
    volume = ignore
    

    Save the changes and exit nano.

    Create a backup of the corrected analog-output-headphones.conf:

    sudo cp analog-output-headphones.conf analog-output-headphones.fixed
    

    Now you can restore the fix if a future installation or update overwrites it.

    Reboot.

    After rebooting, you may need to remove and reinsert the headphone plug to get it to work. After it's working, though, you will be able to remove and insert the plug, and behavior will be as expected.

    Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.

    ...like a charm.

    On LUbuntu 12.04 this doesn't work for me. Also you can reload the sound system, by first killing pulseaudio `pulseaudio -k` and restarting alsa: `sudo alsa force-reload`. No reboot needed.

    Just a note. I set pulseaudio not to auto respawn as I was trying various fixes to this problem. When I rebooted my system, the problem seemed to persist (speakers good, headphones not). When I realized that pulseaudio isn't even working, I reset it to auto respawn and rebooted. And yay! I have my headphones back!

    Except this gets overwritten every time your system updates pulseaudio.

    This did not work on a 2013 Dell XPS 13 running Ubuntu 16.04.

    Worked like a charm on my Alienware m14x running Ubuntu 16.04

    worked for me too, Ubuntu 16.04 on Dell 6410.

    Not for me, Ubuntu Mate 16.04, Asus x202e.

    Worked like a charm on Linux Mint 18 (ubuntu 16.04) and dell inspiron 1510. No need to reboot either. Worked right away.

    @MarkStosberg did find anything for dell xps 13 eventually?

    @OmidHezaveh No. I still use alsamixer to manager my volumes now instead of the usual system volume management.

    @MarkStosberg I wish I could do the same. In my case even alsamixer doesn't help. Sound comes through both head phones and the speakers, no matter what I do in alsamixer.

    This was bugging me a lot. Thanks for fixing it. This is godsend.

    Worked like a charm for Debian 9 in Toshiba Satellite. Thanks a bunch!

    This worked for me on a Dell XPS 13 (9350). Rebooting pulseaudio as suggested by Calmarius wasn't enough for me, I had to reboot my laptop entirely for it to work.

    On my HP spectre 360 and Ubuntu 18.04 this didn't work yet (previously on 14.04 my headphones were working, though I also had to fix it).

    Worked for me, Toshiba Chromebook 2 (Ubuntu 16.04.1 LTS).

    Worked, but for some reason my laptop speakers do not get muted when plugging the headphone in. Any directions on where to configure this?

    Worked! Thanks. KUbuntu 19.10 + Dell Vostro 7590

    Note to future self: This worked but you need to SHUT DOWN instead of restart!!

  • i had same issue after installing 16.06 ubuntu gnome in my dell xps. then i solve this issue by .......

    sudo apt-get install pavucontrol
    

    after install pavucontrol. open it by simply typing terminal pavucontrol.

    then go to -> Output Devices tab -> change port

    in my case seleted port was Headphones(plugged in) by default after plug headphone

    enter image description here

    change port Headphones(plugged in) to speakers (unavailable).

    enter image description here


    this is a temporary fix.after rebooting your pc you have to do this again.

    Great tool, exposed everything that I needed to find out what was going on, without any ugly config hacks.

  • The solution in a comment above by buzypy worked for me, without any of the other stuff:

    sudo alsa force-reload
    

    then reopen pavucontrol and change to the option Headphones (unplugged) and restart the program that was playing the sound.

    It's problems like this that make people not want to use Ubuntu!

    Yeeee-haw. After mod probing and alsa installing and muting and unmuting etc etc etc... <3

    All I had to do was run "sudo also force-reload" and it started working right away. (Ubuntu 19.10)

    Doesn't work for me. 20.04

  • I had the same issue. I did as below

    • Go to Settings
    • Click on Sound settings under hardware section
    • Click output tab (automatically selected by system)
    • On the bottom side: set the output volume to 100%

    Thanks to https://superuser.com/questions/357623/headset-is-not-working-with-ubuntu-11-10

    i already have tried that . not working

    Not a solution because only headphones jack isn't working.

    Helped for me. My headphones were muted for some reason.

    For Ubuntu 18.04 Under Output Tab Selecting 'Line Out Built-in Audio' helped restore sound.

  • On my laptop, a Lenovo G465, the sound was working well: each time I plugged the headphones, it would be detected and sound was piped through the headphones and muting the speakers. Suddenly it stopped working. Something weird happened without any changes or installation or whatsoever. I read that someone had to use alsamixer to activate it: lo and behold: I tinkered with the volumes and mutings and suddenly it started working again as before!!! I have no explanation, honestly.

    Experiencing the same thing with my Lenovo laptop this morning :) Playing with sound settings though nothing seem to help - I hope it starts working again like in your case :)

    Rebooting helped :)

  • In my case, for a Dell E5450, it was resolved after runnning:

    sudo modprobe snd-hda-codec-idt
    
  • To day I got it in easy way:

    How to using headphone in Ubuntu:

    1. Install update for Ubuntu.
    2. Install GNOME alsa mixer.
    3. Plug in both of back speakers and front headphone.
    4. In ALSA: mute your front column, unmute in Headphone.
    5. Go to Sound setting: unmute your sound that was made by ALSA.
    6. Click the Test Sound button to go to Test Sound in Sound settings, check left and right ==> ONLY HEADPHONE has sound, Speaker will be silent.

    enter image description here

    enter image description here

    enter image description here

    IMG:

  • I had to do the following:

    1. Exit out of google chrome (I'm trying to get music to play in a tab)
    2. in a terminal, run killall chrome -- will probably say "none found" or whatever
    3. kill pulseaudio with pulseaudio -k at a terminal. (it should restart silently in the background, but if not, try pulseaudio -d)
    4. now run sudo alsa force-reload (Thanks @mjp!!)

License under CC-BY-SA with attribution


Content dated before 6/26/2020 9:53 AM