AMD-V is not enabled in VirtualBox on AMD APU

  • I am running on a dual core AMD E450 CPU. When I tried to run a 64-bit OS that requires hardware virtualization using VirtualBox, it showed me an error message that "AMD-V is not enabled".

    My AMD processor is supposed provide AMD-V support, but I can find no option for enabling AMD-V in BIOS.

    How can I solve this problem? How can I enable AMD-V for my CPU?

    Thanks in advance

    lscpu :-

    Architecture:          x86_64
    CPU op-mode(s):        32-bit, 64-bit
    Byte Order:            Little Endian
    CPU(s):                2
    On-line CPU(s) list:   0,1
    Thread(s) per core:    1
    Core(s) per socket:    2
    Socket(s):             1
    NUMA node(s):          1
    Vendor ID:             AuthenticAMD
    CPU family:            20
    Model:                 2
    Stepping:              0
    CPU MHz:               1650.000
    BogoMIPS:              3291.72
    Virtualization:        AMD-V
    L1d cache:             32K
    L1i cache:             32K
    L2 cache:              512K
    NUMA node0 CPU(s):     0,1
    

    EDITED:-

    Error message from VirtualBox:-

    Failed to open a session for the virtual machine XXX.
    
    AMD-V is disabled in the BIOS. (VERR_SVM_DISABLED).
    
    Result Code: NS_ERROR_FAILURE (0x80004005)
    Component: Console
    Interface: IConsole {1968b7d3-e3bf-4ceb-99e0-cb7c913317bb}
    

    If there really isn't any option related to virtualisation in your BIOS, then your only option may be to contact the BIOS vendor and ask if they can add one. Once the CPU feature has been disabled in this way, it can't be re-enabled without rebooting (at which point, the BIOS code disabling the feature will run again).

    correct answer is already on both answers below...

    @JamesHenstridge - I have encountered BIOS that had HW Virt disabled, but vendors I'm willing to buy from have ceased or lessened this practice. HP, for example, has gotten much better about this in recent years.

    Bios default is disabled in Hp notebook running E450 CPU. Installing took over 4 hours and cursor movement etc. was very slow but enabling in bios did the trick, Ubuntu runs on Win7 ok.

    try decreaseing the memory allocated for your virtual machine.

  • RobotHumans

    RobotHumans Correct answer

    8 years ago

    First enable AMD-V in the BIOS. It depends on your BIOS, but it will look something like this (probably):

    enter image description here

    In VirtualBox click -> Settings -> System -> Acceleration and enable the checkboxes as shown below.

    enter image description here

    i said before, i don't have any option for virtualization in BIOS but my processor support virtualization.

    then you need to buy new hardware or try the second half of the answer

    @hbdgaf the acceleration option is greyed out.

  • I had run into the very same problem and after spending like 2hrs I finally solved this. I am on a 32bit sys and my Bios does not have this Vizualization Technology option.

    The problem happened to be VirtualBox related, I did this:

    VirtualBox > System > Processor > change the number of processors from 2 to 1

    Worked for me.

    This works for me too. I have the virtualization enabled in BIOS, but I had 3 processors enabled in VBox.

License under CC-BY-SA with attribution


Content dated before 6/26/2020 9:53 AM