"Dependency is not satisfiable" error when trying to install an application

  • When I try to install glchess in Synaptic

    glchess install

    I get this error error

    At a certain time I installed the Gnome desktop and a lot of games that came with it and then uninstalled the games. Now I want chess back. When I downloaded the deb file and tried to install it in Gdebi I got a similar error: install error glchess

    What should I change in repositories?

    can you pastebin.com the output of `sudo apt-get update && sudo apt-get upgrade` as well as `sudo apt-get install -f`

  • fossfreedom

    fossfreedom Correct answer

    8 years ago

    From your pastebin it looks very much like you have not got the updates repository enabled

    enter image description here

    Tick this option shown - the refresh your installation before install pyChess

    sudo apt-get update && sudo apt-get upgrade
    

    indeed it was not checked !! (i guess i was trying to avoid the the repeated upgrade announcements). thank you. maybe question should be edited to become more inclusive and useful

    by the way, may i know what image editor you used to create your illustrative image above?

    @cipricus He probably used shutter - its in the repositories.

    its a screengrab from `shutter`

  • sudo apt-get build-dep glchess
    

    would that work for other programs? i got my answer for this one but now i have a similar issue with installing a dictionary (ubuntudico), which i cannot install from deb because of a similar error

    It worked for me while I was having having the similar situation. Maybe it can work

    for ubuntudico2 it doesn't work. for chess i already solved it as seen in another answer

License under CC-BY-SA with attribution


Content dated before 6/26/2020 9:53 AM