Come installo glib?

  • Voglio creare Empathy in Ubuntu 11.04. Quando seguo il processo di creazione,

     ./autogen.sh
    

    Me l'ha detto la conchiglia

    libtoolize: copying file `m4/lt~obsolete.m4'
    checking for autoconf >= 2.53...
    testing autoconf2.50... not found.
    testing autoconf... found 2.67
    checking for automake >= 1.9...
    testing automake-1.11... found 1.11.1
    checking for libtool >= 1.5...
    testing libtoolize... found 2.2.6b
    checking for glib-gettext >= 2.2.0...
    testing glib-gettextize... not found.
    ***Error***: You must have glib-gettext >= 2.2.0 installed
    to build Empathy.  Download the appropriate package for
    from your distribution or get the source tarball at
    ftp://ftp.gtk.org/pub/gtk/v2.2/glib-2.2.0.tar.gz
    

    Ma quando non riesco a trovare il modo per installare glib. Cosa dovrei fare installarlo in Ubuntu 11?

    Perché chiedi "gnome-common" che non è nemmeno menzionato in quell'output?

    @enzotib ho rivisto il titolo per adattarlo a ciò che viene realmente chiesto.

  • Hai bisogno libglib2.0-dev per glib-gettext. Puoi installarlo con

    sudo apt-get install libglib2.0-dev
    
  • devi anche installare libgtk2.0-dev per installare glib completamente (glib fa parte di: libgtk2.0-dev)

    sudo apt-get install libgtk2.0-dev
    

    vedere questo collegamento per ulteriori spiegazioni: installazione di gtk e glib

    Questo ha risolto il mio problema. Ho già installato "libglib2.0-dev" ma ho riscontrato problemi durante l'installazione di "gobject-introspection". Ho provato a installare glib manualmente ma non ha aiutato.

  • Ti consiglio di cercare i ppa disponibili se vuoi solo controllare l'empatia più recente di quella che hai. io penso questo ppa è la soluzione migliore Oppure fallo

    sudo add-apt-repository ppa:telepathy/ppa

    O se hai bisogno di costruirlo.

    sudo apt-get build-dep empathy

    che installerà tutte le dipendenze necessarie per creare empatia dalla fonte.

    C'è bisogno di dire che `build-dep` installerà tutte le dipendenze richieste per costruire la versione repo di empathy. La versione più recente potrebbe richiedere anche altri pacchetti o versioni più recenti di alcuni pacchetti.

    @sagarchalise quando uso il secondo comando per compilare, ha detto la shell. Lettura degli elenchi dei pacchetti ... Fatto Costruzione dell'albero delle dipendenze Lettura delle informazioni sullo stato ... Fatto E: La dipendenza Build-Depends per l'empatia non può essere soddisfatta perché nessuna versione disponibile del pacchetto libnotify-dev può soddisfare i requisiti della versione

Licenza sotto CC-BY-SA con attribuzione


Contenuto datato prima del 26/06/2020 09:53