¿Cómo instalo glib?

  • Quiero construir Empathy en Ubuntu 11.04. Cuando sigo el proceso de construcción,

     ./autogen.sh
    

    La concha me dijo que

    libtoolize: copying file `m4/lt~obsolete.m4'
    checking for autoconf >= 2.53...
    testing autoconf2.50... not found.
    testing autoconf... found 2.67
    checking for automake >= 1.9...
    testing automake-1.11... found 1.11.1
    checking for libtool >= 1.5...
    testing libtoolize... found 2.2.6b
    checking for glib-gettext >= 2.2.0...
    testing glib-gettextize... not found.
    ***Error***: You must have glib-gettext >= 2.2.0 installed
    to build Empathy.  Download the appropriate package for
    from your distribution or get the source tarball at
    ftp://ftp.gtk.org/pub/gtk/v2.2/glib-2.2.0.tar.gz
    

    Pero cuando no puedo encontrar la manera de instalar glib. Qué tengo que hacer instalar eso en ubuntu 11?

    ¿Por qué pide `gnome-common` que ni siquiera se menciona en ese resultado?

    @enzotib Revisé el título para que coincida con lo que realmente se pregunta.

  • Necesitas libglib2.0-dev para glib-gettext. Puedes instalarlo con

    sudo apt-get install libglib2.0-dev
    
  • también necesita instalar libgtk2.0-dev para instalar glib por completo (glib es parte de: libgtk2.0-dev)

    sudo apt-get install libgtk2.0-dev
    

    vea este enlace para obtener más explicación: instalando gtk y glib

    Éste resolvió mi problema. Instalé `libglib2.0-dev` antes, pero tenía problemas para instalar` gobject-introspection`. Intenté instalar glib manualmente pero no ayudó.

  • Le recomiendo que busque los ppa disponibles si solo desea verificar la empatía más nueva que tiene. pienso esto ppa es la mejor apuesta O simplemente haz esto

    sudo add-apt-repository ppa:telepathy/ppa

    O si necesita construirlo.

    sudo apt-get build-dep empathy

    que instalará todas las dependencias necesarias para generar empatía desde la fuente.

    Necesito decir que `build-dep` instalará todas las dependencias necesarias para construir la versión de repositorio de empathy. La versión más nueva también podría requerir otros paquetes o versiones más nuevas de algún paquete.

    @sagarchalise cuando uso el segundo comando para compilar, shell dijo. Leyendo listas de paquetes ... Hecho Construyendo árbol de dependencia Leyendo información de estado ... Hecho E: La dependencia de Build-Depends para la empatía no se puede satisfacer porque ninguna versión disponible del paquete libnotify-dev puede satisfacer los requisitos de la versión.

Licencia bajo CC-BY-SA con atribución


Contenido fechado antes 26/06/2020 9:53